Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #5984

    When looking at a category of posts there are 4 small posts at the bottom of each page – how can I remove this feature?

    View here: http://www.nicolamorgan.com/author/books/

    #52461

    Hey,

    you can:

    1) Increase the number of fullwidth posts (Newscast Options > “Article Appearance on frontpage and category overview pages” – set it to 10 or more)

    2) Decrease the posts per page value (Settings > Reading – change 10 to 6).

    #52462

    Did that which removed the small posts. Now the category paginates to 3 pages but when you click the 2nd or 3rd page it says:

    ERROR 404

    We are sorry, the page you are looking for does not exist

    #52463

    Very strange – maybe a plugin or permalink problem. However reset the settings (like you used them before) and open up archive.php. Replace following code:

    if ($fullsized > 0) :

    with:

    if (1 > 0) :

    This will “hardcode” the fullwidth posts.

    #52464

    Changed the line of code as you said and now have ‘Reading’ > ‘Blog pages to show at most’ set to 10

    and in Newscast Options > Article Appearance on front page….. set to 6

    But now the small posts still appear and the same error message also appears when you try to move to the next page of posts?

    #52465

    …..also, I disabled all the plugins and the problem still remains.

    #52466

    Hi Dude,

    I’m guessing that this problem has been there a while and it’s only now that the theme is finished and i’ve started to add more content that the issue has become apparent.

    So i decided to reload the original archive.php file just in case anything had been changed but this didn’t make any difference – when you move to any page other than the first page it says ERROR. The weird things is it knows that there are more posts and can determine the number correctly as the pagination navigation shows the correct number or pages for however many posts I publish – the theme just can’t display them. :o(

    I’m not so concerned about removing the small post format at the moment as this new issue is a real show stopper.

    Any help would be much appreciated.

    Thanks

    #52467

    Please try if it’s a permalink problem or not. Go to Settings > Permalink and set them to “default structure”. If this doesn’t help it’s a theme problem (however very strange because other users don’t experience this error…)

    #52468

    Dude you’re a genius, I changed the permalink structure back to default and it worked!

    Previously I had:

    /%category%/%postname%/

    is there any way to use a SEO friendly structure with the theme?

    K

    #52469

    Yes of course. It seems to be a problem with your htaccess file/server configuration. Please have a look at to this WordPress Codex entry: http://codex.wordpress.org/Using_Permalinks

    #52470

    Hi Dude – i found the cause. I installed a new copy of the theme and kept adding my plugins until the error occurred. It was caused by a plugin called ‘Top Level Categories’ that removes the category from the permalink. I thought i had tried it with all of the plugins disabled but this could not have been true. So everything is working fine now – thanks for all your help!

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Remove small post format when viewing a category of posts’ is closed to new replies.