Tagged: ,

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #22660

    Hi,

    When a user clicks a Portfolio item, it brings them to another page with the enlarged portfolio view and the description to the right. Is there a way for me to remove the “hover / lightbox” feature on this image? I have the portfolio setup as “Show on Single Page” which display the thumbnails as links to the larger image and description, however once on this page, I don’t have the need to the hover. I would like a solution that I can either place in my child theme folder or as Custom CSS (since I would like to avoid making these changes everytime there is an update if possible)

    Thanks

    #116691

    Here is the link for reference: http://goo.gl/l2sVM

    #116692

    Anyone have a suggestion for this? Thanks

    #116693

    Hi,

    Add this on your custom.css

    .single-portfolio .image_overlay_effect.lightbox_image, .single-portfolio .image_overlay_effect_inside {
    display: none !important;
    }

    Regards,

    Ismael

    #116694

    Hi, This remove the hover image, which is great, however I’d like for the lightbox to be disable all together on these if possible…

    Thanks!

    #116695

    Hey!

    Open up angular/js/avia.js and replace:

    jQuery.noConflict();
    jQuery(document).ready(function(){

    with:

    jQuery.noConflict();
    jQuery(document).ready(function(){
    jQuery('.single-portfolio .slideshow a').find('img').unwrap();

    Regards,

    Peter

    #116696

    This doesn’t resolver the issue…. when a user clicks on a portfolio item and is brought to the single portfolio page, the images still load up the lightbox when clicked… Anything else I can try??

    The first image in the set has to “link to the post” in order to open the single page, so it’s this image that is causing the lightbox to open…

    #116697

    I just checked your avia.js ( http://www.createdesign.ca/newsite/wp-content/themes/cre8iv/js/avia.js ) and I can’t find the code I posted above – please add it and we’ll check why it doesn’t work.

    #116698

    It works now! I have no idea what happened, but it works. I had tried it, didn’t work, so then I put the old code back in…. Just updated it again so you could view, and now it works? Maybe a refresh issue on my end??

    Anyways, it’s functioning the way it should – Thanks!

    #116699

    Question – Is there a way for me to get this file to function in my child theme?? In case of future updates, I’d like to keep this function…

    Thanks

    #116700

    Hi,

    These tutorials explain how to add jquery to your child theme

    http://steveminordesign.com/2011/02/adding-custom-jquery-scripts-to-a-wordpress-child-theme/

    The thing is, you will still need to do a character by character comparison between your avia.js and the avia.js that is being updated because the update could well rewrite that section of the code.

    Also try creating a js folder in your child theme and drop the avia.js file inside it.

    THanks,

    Nick

    #116701

    I like to use a different lightbox plugin for few post. So how can I disable the current lightbox on few post and portfolio items?

    #116702

    If you want to deactivate the default lightbox which comes with the theme open up angular/js/avia.js and delete

    //activates the prettyphoto lightbox
    if(jQuery.fn.avia_activate_lightbox)
    jQuery('body').avia_activate_lightbox();

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Remove the Hover (magnifying glass / lightbox) on Enlarged Portfolio Item’ is closed to new replies.