Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #187104

    I’m probably overlooking something simple, but I can’t figure out how to remove the underline and background hover effect on linked images. You can see the development site here: http://www.newlevelgraphics.com/dev/shows/

    I like this effect on text links… just not on images. :)

    Thanks!
    Heather

    #187230

    Hi Heather!

    Do you have a plugin that inserts a script on images? Please add this on your custom.css or Quick CSS:

    #top .entry-content p a:hover {
    background-color: transparent;
    }

    Regards,
    Ismael

    #187435

    Ismael, I don’t have any plugins that would do that… I just had delete revision and backup plugins turned on. I turned everything off, but that didn’t fix the issue.

    I added the code you suggested, but now my header background disappeared and there was still a hover effect on these images. Only, there was a thin red line which disappeared on hover.

    I removed all the custom.css content to be sure it wasn’t any of my customizations causing this, but it’s back to looking like a text link (red line which gets thicker when hovering).

    If you take a look now, there is no custom.css and no plugin turned on. But I’m still getting this problem.

    Any ideas what to try next?

    Thanks!
    Heather

    #187602

    Hi!

    Please try this code. It works when I tested it:

    .entry-content p a {
    border: none;
    }
    
    #top .entry-content p a:hover {
    background: none !important;
    }

    Remove browser cache then reload the page.

    Regards,
    Ismael

    #187627

    Ismael, I’m editing this post because I realized that didn’t fix the issue completely. It removed the red on the images, but it also caused all my text links to disappear on hover.

    So, I still need to figure out how to remove the hover styling on linked images but not on text images…

    Thx,
    Heather

    • This reply was modified 10 months, 2 weeks ago by  vibeGirl. Reason: update to the issue
Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Removing CSS Style on Linked Images’ is closed to new replies.