Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #20248

    For some reason I cant remove the default sidebar on the shop page. When I add my own widget area (via the template builder) it shifts over the default area and leaves space for my custom sidebar but nothing appears even though I’ve added widgets.

    Here is a link to the page: http://tailoredbystephenb.com/?post_type=product

    I want it to look like my sub pages, here is a link: http://tailoredbystephenb.com/?page_id=75

    Lastly, I added the product filter to the sidebar underneath the navigation but its not appearing for some reason. Any help is appreciated, thanks a lot.

    #106876

    Hi pwsanders,

    Woocommerce will overwrite any template made with the template builder and attached to a page. The sidebar for the shop page is only set via the Appearance>Widgets and Sidebar:Shop Overview widget area.

    Both of the links above are giving me 404 errors so I’m not sure if this is exactly what you are looking for.

    Regards,

    Devin

    #106877

    Im not getting a 404 error when I click them (I had some friends to also check on there PC’s).

    http://tailoredbystephenb.com/?post_type=product

    http://tailoredbystephenb.com/?page_id=75

    Here they are again… thanks in advance for your help.

    #106878

    I’m able to connect now, but the pages are showing no results for the post types.

    Just to be clear, you can’t use a template builder template for the main shop page. The shop is determined by woocommerce and the theme. So when you set the page that holds the shop in the woo commerce settings>pages, that page will then display the shop.

    If you also add a template to that page, it won’t have any effect.

    #106879

    Oh ok… that made your first reply a lot more clear. Thanks I will give it a try and inform you on the results.

    #106880

    Ok, I’m in woo commerce settings>pages but its not allowing me to define sidebar position or add widgets… that’s what I’m trying to do.

    #106881

    Also, I created an image that is 200px by 100px, however when I upload it the image is cut off. Thanks in advance for all of you assistance.

    #106882

    You add widgets in the Appearance>Widgets area. The widget area will be labeled “Shop”. You just drag and drop the widgets to it there.

    For all products you should use images that are at least 450x450px. That will give you clear and non-pixelated images.

    #106883

    OK thanks Devin. What about px size for the logo? I’m sorry, I wasn’t clear in my last post but that’s what I was referring to when I said that I created an image that is 200px by 100px.

    #106884

    It looks like when you inserted the logo, using the button, you may have chosen the thumbnail size on accident. Remove the logo from the theme options (just hit the red x). Then use the image url that you’ve already uploaded in that field and save:

    http://tailoredbystephenb.com/wp-content/uploads/2013/02/TBS.png

    That is the direct url to the image.

    Regards,

    Devin

    #106885

    Hey, thanks Devin for all of your help… hopefully I won’t be bothering you anymore!

    #106886

    Glad we could help :)

    Let us know if you have any other questions or issues.

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Removing the default sidebar on my 1st shop page’ is closed to new replies.