Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
  • #3363

    Dear Avisio Gurus~

    I downloaded the new set of files for Avisio 1.2 at Themeforest to get the new version. I opened the folder and noticed a MS Word document that gave info about what files and folders were updated in the new Avisio 1.2 Version.

    I updated all files perfectly. But, when I updated the header.php file, it broke my site.

    What files exactly do I need to replace to use the new Avisio 1.2? My Portfolio page is not working because of the new URL slugs and I want to fix it.

    PLEASE HELP. Thanks,



    Have you tried to reset your permalinks? Go to Settings > Peralinks and click on the “Save” button.

    Version.rtf tells you which files were modified. You can use notepads like “notepad++” to compare the old header.php with the new version. The “compare” feature marks the differences for you :)



    I have downloaded v1.2.

    I am now getting an error on line 78 of the header.php.

    “Fatal error: Call to undefined method kclass_advanced_css_style::set_element_background_image() in C:Inetpubvhostsassuredynamics.comhttpdocswp-contentthemesavisioheader.php on line 78″

    Comparing the two header.php there appears to be additional/new lines setting the background image.

    Any advice?




    @Niall ~

    I’m getting the same error message as Niall.




    Sorry, it seems I forgot to mention two files to update:

    kclass_advanced_css_style.php located in framework/classes/ and

    portfolio.php in theme_options

    Once that is updated you should be good to go :)

    Best regards,




    How do I mark this topic as “solved”?



    Thanks Kriesi,

    I have uploaded the two files and version 1.2 of the theme is working great – thanks!

    I can start a new thread if necessary, but I just think it would be a good idea if we could get a summary of how to get the permalinks working again.

    I have followed the master list of fixes, but as soon as I go for a custom permalink “month/name”, then the portfolio items go 404. If I use the default permalink, the portfolio items work fine when clicked within the site, but all external links just go to the home page.

    I have been battling for two weeks to get our site right after the WP 3.1 ‘upgrade’.

    I would really appreciate a heads up on what is the best course of action now.





    The portfolio permalink was a pretty common support request following the WP3.1 upgrade. The problem is in duplicate naming of a Custom Post Type, which the Avisio portfolio is, and another page/post/category in your site.

    Simply edit the slug of your Portfolio page from “portfolio” to “work” or something of that ilk. This will fix the linking issue that was returning a 404.

    You can see a bit more here:




    I am having the same problem with portfolio items returning 404 errors since upgrading to 3.1, but I don’t understand the above solution. Can you elaborate on the exact steps we need to take? We have custom permalinks that are category/post-name/

    All of our items have “portfolio” in the slug, so the URL looks something like this:

    We have 224 portfolio items so I am hoping that we won’t have to go in and edit each one individually.

    Thank you!


    Did you update portfolio.php in theme_options folder? Did you flush the permalinks by going to Settings > Permalinks and clicking on the “Save” button? Please check if the category base field on the permalinks setting page is empty. You permalinks should have the structure: now. WP3.1 doesn’t allow the caregory slug anymore…


    Thank you for answering so fast!

    Yes, permalinks have been removed and then added back, so they should be refreshed.

    Yes, my URLs are showing “category” in the slug still.

    I have not gone into portfolio.php, what do I need to do in there? I see a file named “template_portfolio.php” – is that what I need to modify? I didn’t see any place to modify it through the Dashboard when I went under Avisio options, do I need to do this through FTP?



    I read and re-read your reply, and decided to upload the latest version of Avisio, and then located the portfolio.php file in the theme options folder, but before I messed with it, I decided to re-save the permalinks setting one more time and Wham! It worked this time!

    Thank you so much.


    Glad that it works now :)


    We’ve followed the steps for the upgrade as indicated in this forum, and we do not have a conflicting url with another page/post.

    We’ve replaced the files as indicated, and we’ve reset the permalinks in the admin

    you can find our link to our problem here:

    Whenever we change over to friendly urls, we get 404 errors on each of the portfolio gallery links.

    Please advise.



    according to the framework meta you’re using version 1.1. The latest version is 1.2.1 – it fixes various bugs with WP3.2, the permalink problem and IE9.


    DUDE: As I stated in my original post, as well as the topic of this forum: i’m looking to only replace the files necessary to update our theme, as we’ve made modifications to parts of the original files.

    I replaced ONLY the files as indicated at the top of this forum. What else do i need to replace?


    Can you create me an admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it. Not sure which files are missing….


    Per Kriesi:


    Sorry, it seems I forgot to mention two files to update:

    kclass_advanced_css_style.php located in framework/classes/ and

    portfolio.php in theme_options

    Once that is updated you should be good to go :)

    Best regards,


    I’ve done this, and I’ve RESAVED MY PERMALINKS: it did not resolve my permalink issue. Please advise.


    Fixed it :)


    I seem to have lost the Portfolio entries section in 3.1 Dashboard sidebar. I can get there using the direct URL – BTS – What is the post_type for portfolio item categories?



    it sounds like theme_options/portfolio.php is missing or corrupt. Try to (re)upload this file. The portfolio categories are terms and are assigned to the “portfolio_entries” taxonomy (the code can be found in theme_options/portfolio.php)


    I downloaded all the latest files, including the portfolio.php file, (re)uploaded all of them to my site, deleted all cache, and the Portfolio Entries section is still not present on the dashboard.

    After looking at the Portfolo.php file and a little trial and error I discovered the Direct URL to portfolio cats –

    Also, there is a lot of discussion above about permalinks, what they should be and re-setting.

    /%category%/%postname%/ is what I have saved. Is this still correct?


    I know some users/experts who recommend against %category%/%postname%/ because of resource reasons, etc. (this structure can cause longer page loading times on large websites). Personally I use this structure nevertheless because it gives me reasonable urls whereas some numbers or date slugs aren’t “pretty” or useful in any way. However if you’ve a news website/large website (many entries) or if you need to take care of page loading times (i.e. slow hardware/hoster) you should use another structure. An overview can be found here:

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘Replace Certain Files for New Avisio Update’ is closed to new replies.