If you have troubles since the update to WordPress 4.5 please read this post before opening a new thread.

Viewing 30 posts - 1 through 30 (of 39 total)
  • Author
  • #18977


    how can I change the language from default English to German (using the de_De.mo und de_DE.po) in the frontend?




    Replete already comes with german translation files (de_DE,po & mo in the replete/lang folder). A (slightly) updated version of the de_DE.po/mo can be found here: http://www.mediafire.com/?z0lpg19yuz4v44d

    You must use the german version of wordpress which can be found here: http://de.wordpress.org/


    Hello there,

    some of the item/text are not translated into the desired language:


    “View our Bestsellers”

    “Recent blog entreis”


    How can I do?



    Yes, the included po file is not up to date. You can use the german files I posted above or following default.po: http://www.mediafire.com/?bx8ea3a810p68pb to update your language file


    Thanks a lot for your response! My language-problem is solved with your solution!


    Thank you for your answer.

    I translated all the entries in the language file from english to french, long work …

    Anyway, some text are now translated (cart > panier) but a lot are not : “Featured Product”, “View our Bestsellers”, etc.

    Where and how can I modify this?



    Afaik these text strings are part of the woocommerce plugin code and you need to translate/use the woccommerce language files to translate them. You can find the latest version of the french translation files here: https://github.com/woothemes/woocommerce/tree/master/i18n/languages



    is the contact form part of the theme?

    I ask because of 2 issues:

    the form labels (subject, priority, message, agreement, captcha…) is not translated into german.

    (“Senden Sie uns eine Nachricht” does not come from woocommerce lang pack, cause I selected the informal language option which say “Du”).

    I do ie not want to have priority as an selection

    how to modify the contact forms fields?

    Thank you




    sorry found them meanwhile, except of the wording from the captcha: which says: Please prove that you are human by solving the equation*

    where can this text get modified?




    This text is part of the (updated) po file I uploaded here. http://www.mediafire.com/?bx8ea3a810p68pb

    You can use it to update you language file (Catalog > Update from POT file and select the po file). You can also “hardcode” the translation into the contact form php file. You can find the text in replete/includes/contact-form.php


    Hi Dude,

    sorry, may I’m to stupid :-|?

    The link provided above default(3).po does not contain any tranlated strings but only the english strings ie.

    ... PO-Revision-Date: 2012-11-28 16:10...

    example string:
    #: ../config-woocommerce/config.php:685
    msgid "Cart"
    msgstr ""

    all of the msgstr inside are set to “”

    I’ve been looking into the original po file which came with the theme download:

    ...PO-Revision-Date: 2012-04-30 10:33

    this one contains translated strings, but does not have the msgid Cart inside (been searching with poedit and notepad++ for it)

    Should I add this string with an editor by myself, unless I read on the web that this should not be done anywhere else than in a poot file which I do not have available?

    BUT: for testing purpose I’ve put this old one back to the server /themes/replete/lang because it contains a translation for the captcha: “Please proof that you are human by solving the equation” > “Bitte löse die Gleichung um zu beweisen das du ein Mensch bist”

    But in the frontend still the english version is displayed, even whith a fresh created mo file out of this po file.

    Naming of file is correct with WPLANG’, ‘de_DE’ <> de_DE.po

    I’m confused why it does not work

    Thanks for advice




    The german po file (completely translated) can found in the second post: http://www.mediafire.com/?z0lpg19yuz4v44d




    Ah, perfect, thanks, now it works!

    I want to give something back: for those who use the informal german wording (“Du” instead of “Sie” (Ikea-Language)) I changed them. I did them in the oldschool way in uppercase. Also some corrections like “Benutzer” instead of “Benützer” ;-) some missing comas, punctuations, grammars, and other minor issues where changed.

    (due to missing knowledge I did not touch the plural forms, but it looks like none of them need changes:)

    You can download the mo/po files for informal german here:


    Greetings from Vienna :)




    Great thanks. I corrected the formal version.

    Best regards,



    Hallo Peter,

    ein paar Übersetzungsprobleme finde ich noch:

    – wenn man dem Kunden ermöglicht ein Kundenkonto beim Checkout anzulegen wird statt Deutsch leider English “weitergesprochen”

    “Haben Sie sich schon angemeldet? Klicken Sie hier, um sich einzuloggen”

    Wenn man den Link benützt öffnet sich

    “If you have shopped with us before, please enter your details in the boxes below. If you are a new customer please proceed to the Billing & Shipping section.

    Username or email * Passwort*

    Passwort vergessen?”

    – Zudem besteht noch die Möglichkeit unterhalb der Rechnungsadress-Eingabe ein Kundenkonto anzulegen

    “Kundenkonto anlegen?”

    Wenn man die Checkbox aktiviert öffnet sich

    “Create an account by entering the information below. If you are a returning customer please login at the top of the page.”

    Was kann man anders machen? Oder welche Language-Dateien sind nicht korrekt? Ich habe Deine po files von letzter Woche in Benutzung.




    PS: Beim LogIn wird auch “Username or email *” angezeigt…Schöner wäre doch “Benutzername oder Email*”



    Leider sind diese Textteile keine Bestandteile unseres Themes (WooCommerce Texte). Ich würde versuchen dieses Plugin zu installieren: http://wordpress.org/extend/plugins/woocommerce-de/





    ich hatte mich eigentlich absichtlich gegen dieses plugin entschieden da es für mich bisher nicht notwendig erschien. “nur” für diesen bug ein plugin zu installlieren, finde ich nicht gut da mir einige übersetzungen bisher in der standardversion viel sinnvoller erscheinen.

    zudem werden nach installation alle produkte nicht mehr gefunden und eine 404 fehlerseite ausgespuckt.

    bei so gravierenden problemen entscheidet man sich eigentlich gegen ein plugin und übersetzt lieber selbst ;(




    Ja, diesfalls muss man die de_DE.po & de_DE.mo Datei im wp-contentpluginswoocommercelanguagesformal bzw wp-contentpluginswoocommercelanguagesinformal selbst übersetzen. Man kann aber auch die mo/po Datein des Autors hier herunterladen: http://deckerweb.de/sprachdateien/woocommerce-und-extensions/


    Should there be a new language file with the new woocommerce release?



    Yes I think so – The files for WC2.0.2 can be found here: http://deckerweb.de/sprachdateien/woocommerce-und-extensions/

    Best regards,



    hi dude,

    ich würde ja gerne die sprache updaten. leider finde ich im backend im menü keinen reiter “catalog” ich bin noch frisch im umgang mit wordpress. ist dieser reiter in der aktuellen version 3.5.1 enthalten oder bin ich einfach nur blind? ;)

    danke schön für deine hilfe.




    Wenn die deutsche Version von WooCommerce verwendet wird, so wird dieser Menüpunkt vermutlich unter WooCommerce > Einstellungen > Katalog zu finden sein.




    hey dank dir für deine antwort.

    da lag mein fehlter. ich wusste nicht das es eine deutsch version von woocommerce gibt.



    so das hab ich jetzt installiert und in dem menüpunkt “katalog” hat sich von den einstellungen her nichts geändert. nur die texte sind auf deutsch.


    Meine Antwort oben “Catalog > Update from POT file and select the po file” hat nichts mit WooCommerce zu tun sondern bezieht sich auf Poedit. Dieses Tool kann mo/po files updaten wenn man unter “Catalog > Update from POT file and select the po file” diese Funktion auswählt. Diese wird aber sowieso nicht benötigt da man hier: http://www.kriesi.at/support/topic/replete-changing-language#post-91448 oder hier: http://www.kriesi.at/support/topic/replete-changing-language#post-91543 auch schon die aktuellste Version bekommt.


    Das mit dem runter laden hab ich schon verstanden. Ich weiß nur nicht wie ich die Dateien installiert bekomme. denn mit woocommere deutsch werden im Theme ja Aussagen wie: “Featured Products” oder “View our Bestsellers” nicht übersetzt.

    Ich weiß halt leider nicht wie ich diese Aussagen übersetzen kann oder halt einfach die deutschen Files aktiviert?


    so can any body help me? the admin can’t tell me how to change languages. i switched my theme into german and on the frontpage are still english sentences like: “Featured Products” or “View our Bestsellers”. can somebody tell me how i can change that?

    many thanks!


    Die deutschen Sprachdateien werden automatisch verwendet wenn sich diese im Theme Ordner befinden & WordPress Deutschland verwendet wird. Daher die mo & po Dateien in den wp-contentthemesrepletelang Ordner kopieren/hochladen (zB mit ftp) und die Seite neu laden. Wenn man WooCommerce übersetzen will kann man die Dateien von hier verwenden: http://deckerweb.de/sprachdateien/woocommerce-und-extensions/


    es dreht sich nicht um woocommerce sondern die replete eigenen inhalte. wie ich ja schon schrieb werden diese wie z.b. “Featured Products” oder “View our Bestsellers” nicht mit übersetzt. das liegt wohl nicht an woocommerce sondern am theme inhalt.

    wenn ich das ändern will WO muss ich das ändern? mir ne extension runter laden hilft da nicht viel, denn ich verwende wp deutsch habe auch alle sprachdateien im richtigen order und die seite ist trotzdem zu 75% englisch. woocommerce deutsch hilft da auch nichts, denn es zerschießt meine seite und dann werden u.a. die produktseiten nicht mehr gefunden. sorry, dude, du musst mir mal eine antwort geben. seit mehreren tagen erzählst du mir das selbe und gehst nicht auf meine fragen ein.

    so wie das aussieht werde ich wohl das theme zurück geben müssen und mein geld zurück verlangen.

Viewing 30 posts - 1 through 30 (of 39 total)

The topic ‘Replete – Changing language’ is closed to new replies.