Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • #24129

    Hi there.

    I seem to have what appears to be a hidden color layer which even your own styling controls dont change.

    I noticed a few days ago that some of the text was showing through as pure white even though my CSS and your styling system said something entirely different. Because I was using an off-white it sometimes wasn’t obvious so I deleted all my CSS and changed all the theme colors in the styler to something different (just for testing) and yet it was still there! eg for text copy, sub titles etc….

    At the moment the only way I can get rid of this for headings, subs titles is by changing the h1-6 colors in CSS but that cant be right can it?

    Please help

    #122425

    Hi,

    I don’t know what you’re seeing but if you change the font color on Enfold > Styling, it does change. I don’t see any rogue layers interfering with the color that I set on the back end.

    Let me tag the rest of the support team.

    Regards,

    Ismael

    #122426

    Hi there,

    I assure you I’m not imagining it…. Most of my CSS is covering it up now with !important comments. However, in my styling controls there is no pure white and certainly none in my css. If I remove all my CSS and change every single color the white still exists. I’m in the middle of updating my site to reflect my offline version and once I’ve done that ill find one of the offending colors, take a snap shot and give you a link to where it is

    Andy

    #122427

    Hey!

    Can you post a link to a page where you noticed the issue? We’ll investigate the code and fix it if possible.

    Regards,

    Peter

    #122428

    Yep… Im uploading this weekend. When its done ill send you a link

    Regards

    Andy

    #122429

    Hey!

    Ok, I’ll leave this thread open.

    Regards,

    Peter

    #122430

    Hi,

    This CSS will fix the testimonials on live site that are jumping since one a little shorter, the code will hold their heights so that annoying jump of the page as the testimonial box resizes goes away

    .avia-slider-testimonials .avia-testimonial-content, .avia-slider-testimonials .avia-testimonial-content p:last-child  {
    height: 179px;
    }

    Thanks,

    Nick

    #122431

    Hi folks,

    Ok… ive partially updated my site. Now you should be able to see the three issues that have been a problem

    http://www.andypeck.co.uk

    1) Check out the TESTIMONIAL AUTHOR NAME on the home page or the sidebar text on the ABOUT page and you will see PURE WHITE text that shouldn’t be there along with some partially transparent colours. Its subtle but its there (check headings) as ive said, the only reason the other white headings have gone are because ive covered them up in the CSS file

    2) The LATEST NEWS on the HOME page has none of the descriptive text below each image even though it exists in the blog itself. This issue didnt exist before the 1.5 update

    3) Attempting to scale the display to an IOS size creates an effect where the screen gets totally cut in half. The following is the offending CSS…

    /* ADJUSTS LOGO WITHIN HEADER */

    .logo {

    margin-top: 20px !important;

    margin-bottom: 30px !important;

    }

    Again this didnt happen before 1.5 but if I remove it I cant control my logo height

    Cheers

    Andy

    #122432

    Hi,

    Oh, that’s nothing. WordPress’s haunted. I can tell you some storied. I once deleted a website, put a different image on the server, started a new site, reinstalled my browser and the deleted site was still up! and not only that, people were sending me messages and a few even placed orders and I was getting google analytics data. Went for a good two weeks like that.

    Some say when you clone some deprecated private interface without first declaring it … bad stuff happens. Dunno what but I read that after doing that they never find their glasses , ever again. Some of these people haven’t left the parent’s basement in years. Sun would kill them, on the spot, so I believe them. A real puzzle of an enigma..

    You do know you still have that css file that’s encrypted and is enqueued on your installation that I said should be removed a week or more ago, right? Its gone, but its being enqueued somewhere out there. Please remove it from enqueue_style function somewhere on your site.

    Take a look here

    http://i.imgur.com/5zLDnjS.png

    You see all those numbers on the left? That is the number of times the css code for color white can be found in each of your css files right now. That’s a dozen or three selectors with white color, and there are more with #fffffff and white and 255 255 255…. So this isn’t exactly a proper WordPress haunting like that time Booger McGinsky went into the code repository and never came out!

    :) It’s midnight sunday!

    Thanks,

    Nick

    #122433

    Ok….. Cynicism aside Nick. How exactly do I get rid of them as they aren’t in my Child Theme CSS and that the only thing I’ve been tweaking. Deliberately to avoid this. I’ve been keeping to the yellow brick road as it were.

    In regard to the DS Store files. It purely a mac thing. When we last spoke I deleted everything as you said but as soon as I installed 1.5 back it all went. Ill go through and delete again as suggested.

    Now, could I get advice as to what has caused me to stray into the haunted forest and what Wizard of Oz magic you can wield to direct me back to the Emerald City. Failing that should I just give up and head back to Kansas?!!!!!

    Cheers

    Andy

    #122434

    Hi,

    No cynicism. Ghost site true story and so is image where all those white color codes are in css files on your site. Listen, there are internal caches , server caches, all kinds of stuff. There is jQuery problems where css is taken from a different selector. You have a file enqued in your theme somehow, so someone wrote that files location out and added it somehow. And if that happen, I am ready to believe about white colors as well. Read over things I write on the forum.

    Its a waste of time in my opinion, trying to play Sherlock Holmes and the ghost in the machine , because I did enough of that, and let me tell you, that most times you will find nothing( http://www.kriesi.at/support/topic/angular-logo-centers-on-mobile-devices-should-be-left-justified#post-111167 ), but waste lot of time, its not gonna get you anywhere ( http://www.kriesi.at/support/topic/woocommerce-addition-of-items-in-cart-not-correct#post-83790 ) , focus on the goal ( http://www.kriesi.at/support/topic/home-page-slider#post-105249 ). I just added those to show that weird stuff happens, and my advice is consistent, so no cynicism.

    What i would like to know is why your website looks dark grey on Chrome Regular and dark blue on Chrome Canary (developer Chrome version)

    http://www.clipular.com/c?6670378=uPQ5PowG3kaU8qxoSrcZDhZCFOw&f=.png

    http://www.clipular.com/c?7167075=P5mQCtu_YOumXtZW7RL6NySVRcc&f=.png

    Now thats weird, something new I haven’t seen before.

    Thanks,

    Nick

    #122435

    Erm…

    Appreciate what you are saying its just I now dont know if im over my head or to keep going. I was originally going to tweak a dedicated Portfolio theme but it was very prescriptive so I thought i’d give this a whirl but I really do feel im rebuilding a car from almost the ground up and the engineers are losing patients with me now that my car, whilst looking good all the doors fall off when I hit 60!!

    Anyhoo, the two clipular pages you are looking at are two different versions… the grey was up there yesterday and the blue version is what ive set up today.

    unfortunately…. I feel im losing the faith despite the fact I can see the marathon finish in site

    Cheers anyway

    Andy

    #122436

    Hi again…

    Ok, ive done a search and deleted 17 .DS_Store files and have added a block app that will avoid adding them again (fingers crossed). Ive also deleted every single file except the ones ive put inside the Enfold-Child Theme folder. These are: FONTS folder (includes the Bebas set) and the ‘style.css’ file. Thats it!

    Ive not touched the Enfold theme at all so now the only things ive added are within the CSS file.

    The three issues however still exists!!

    I guess I can abandon the idea of using the Fixed Header and revert to the scroll up version which would fix ISSUE 3 but that doesn’t resolve ISSUE 1 (Testimonial desc text) & ISSUE 2 (Colors)

    Andy

    #122437

    Hi,

    Issue 1) What color you need them?

    Issue 2) I will need to login again for that

    Issue 3) This code fixes mobile layout fully as far as i can tell.

    .html_boxed #main {
    overflow: visible !important;
    }

    Thanks,

    Nick

    #122438

    Hi,

    No kidding, I am still working on the grey site. See that’s what I was talking about.

    Your site looks really good in all the colors you’ve done it. You got an eye for this. I can;’t match 2 colors , have to ask people lol.I think you are taking the wrong approach with this, if may make an observation. You are changing awesome looking super hi pro looking site left and right. I do the same but thats because my colors look hideous. You should be entering content and get something up , like 100% up and running and then once the goal is accomplished you can play around with different looks. However I wouldnt throw away those designs you did since each can be part of a living portfolio.

    Thanks,

    Nick

    #122439

    Thanks for the confidence boost Nick,

    Your’e right of course although having come from a Rapidweaver background Im used to using dummy content, tweaking till it works and then populating all the core pages. I worry that if I dont get the main pages right now then when Ive thrown in everything and come back to tweak I wont be able to get what I want and ive committed to everything. Arse about-face way of working but normally I just design front end pages, shoot the video and then hand the rest over to a team to make it happen. Of course I understand the principles so im not trying to land a man on the moon without having a grasp on physics and gravity but even so….. well you get my drift.

    Anyway…

    Im going to do things slightly different. Ive saved all my pages and I will do as you say but just to be sure I wasnt going mad I reinstalled wordpress and both Enfold & Child. I then stripped away all the content (dont worry its backed up) and just made a basic page but changed all the background colors

    Take a look at my site…. andypeck.co.uk

    The orange is the color I tweaked across the board for all fonts and yet look what happens down the right hand side in the side bar. There’s some sort of additional layer making all the copy come out hue’s but not the strength of what I picked in the Styler. Am I going mad or is this an error?

    Also, did the blog shoprtcode (when its in a grid) ever have an except underneanth or has it only ever displayed just the title. I swear it did have a few lines which is why the READ MORE was relevant but having now checked the demo site andcompared it to my own it no longer has it. Was I imagining the except? Has it gone with the 1.5 update or should I just go get my head examined?

    Sorry for long email but thought I should explain

    Andy

    #122441

    Hi,

    I am trying to understand what you are seeing, because this is what I see in Chrome on Windos 7 http://www.clipular.com/c?7180226=65G_ENiS0TuPzhP8gfxP6Nr6feM&f=.png , FF looks same, and so does IE.

    The way the theme works is that a css file gets dynamically generated based on settings in Enfold > Theme Options > Styling. This css file gets written into the upload folder of wordpress (since chances are the server allows file writing there) . In your case this is the file http://www.andypeck.co.uk/wp-content/uploads/dynamic_avia/enfold.css. It is executed right before custom.css in the cascade.

    I just ran an app that counts which selectors in css are used and which are ignored and 98% of css is not used on your site. I have a feeling that maybe some of these selectors may be used somehow even though they are. WordPress 2.6 promises tons of improvements so for now i would just continue building. When you are finished thats the time to remove the unneeded selectors and I have a feeling things will fall in place. If this is done now, then when you add anything extra there wont be a selector to style it, so thats why i suggest you get to the point where you have everything finalized. On top of that its a great optimization technique.

    Thanks,

    Nick

    #122442

    Hi there,

    two things… Firstly Kriesi has just acknowledged that there was an issue with the blog grid and it will be resolved in next update. Secondly, this color debate… the point im making is that (for argument sake) lets say I make every single color a strong orange and just the background is black. Why am I seeing derivatives of that color which (on your Clipular grab) show that there are loads of tinted ranges of the only orange color i chose. eg… the titles CATEGORIES & the blog…THE EYES HAVE IT show up as a vile yellow which is an opacity level of the only Orange color I chose (as shown in HOME – top left)

    As ive said… the only way I will get rid of this is to literally add line after line of CSS code to kill it. Why cant I kill the white globally and only have my colors chosen in the styler as the colors I want (without the transparency/opacity)???

    Andy

    #122443

    Hi,

    Ahh, so the background color on my snapshot, for sidebar, content area, socket and header is not the color you selected. Should have said just that, because how am I supposed to know.

    Been looking , and even though that black color you have is exactly the color if 10.5% transparent black is painted on white, in reality it is color #191919 and it is used on page /includes/admin/register_backend_styles.php on lines 625,638,690, and 704. I think if you change that to #000, your troubles may be over!

    changing that produced for me http://i.imgur.com/3QQMkvt.jpg

    There are a couple other colors hard coded on the page and I think you will find all the ones that been showing up

    ============

    I also got plan B lined up. I am gonna give you a new css file with all extra css removed which will take the place of enfold.css

    I looked at all the transparency css, and also found this :

    #top .socket_color .avia-color-theme-color {
    color:rgba(0,0,0,0.5);
    }
    #top .header_color .avia-color-theme-color {
    color:rgba(0,0,0,0.5);
    }
    #top .main_color .avia-color-theme-color {
    color:rgba(0,0,0,0.5);
    }
    #top .alternate_color .avia-color-theme-color {
    color:rgba(0,0,0,0.5);
    }
    #top .footer_color .avia-color-theme-color {
    color:rgba(0,0,0,0.5);
    }

    They can be neutralized by changing 0.5 to 0.0

    Thanks,

    Nick

    #122444

    Hi Nick…

    I kinda thought I had said it but maybe I wasnt explicit enough! Anyway to be sure here’s my own Clipular link with some text to explain what I mean.

    http://www.clipular.com/c?6518370=wwDhFGC78iMolbemdBVV0mgcX-4&f=7a598bd5a4321bc47cf6d33218142f3d

    The CSS file you are talking about. Where will I find this?

    Almost there I hope and then I can get on with building!

    Andy

    #122445

    The concern I have more than anything though Nick is surely having to add CSS just to kill this opacity stuff isn’t it right is it? Is there a reason for this because surely that means people arent designing to a specific value anymore and sites arent accurate because Headers and the such like are really coming out as different values?

    This feels wrong to a designer like me but then am I missing something? If I kill these opacity layers will I hit a brick wall later down the line but just haven’t seen it yet? Have I missed the point of this and I should rethink what Im doing?

    Cheers

    Andy

    #122446

    Hi,

    Yes. Your image shows no yellow color in the header, the section you were editing. Have you changed the yellow also in the body section or alternate section? See image http://i.imgur.com/YWr6qVn.png

    The very top color changer for background doesn’t seem to be working , but you can just paste the color in there.

    Because I easily was able to change the yellow you are pointing to in one of the other sections, alternate I think.

    Thanks,

    Nick

    #122447

    Hi,

    Its there because most people are like me and are incapable of matching colors. With this , they now can pick a few colors and the tones will be created for them based on the main colors, the shades and all that by adding a % transparency. If the colors here aren’t used and instead are styled as i showed you long ago using css and chrome developer tools, then all would be well and none of this would be bothering you. :)

    But in any case, tell me locations just like u did there with the arrows, and i can get you the color css for it, and u can change it easily yourself.

    THanks,

    Nick

    #122448

    Hi Nick,

    I have been changing the CSS as ive been going along (just like you showed me – hence ive achieved sooooooo much knowledge thanks to you) but I didnt understand why the % transparency was used. I was so tied up with the belief you ‘techies’ always dealt with exact values that I didnt think for a minute Kriesi had put in a ‘paint by numbers’ design system. It all makes sense – I just wanted it explained so I didnt think I was going mad! Its not something I think can explained by just trawling the web

    Anyway, I think I can get back on track now. If… the following code effectively shuts off the transparency and I can add my own then I can get on.

    #top .socket_color .avia-color-theme-color {

    color:rgba(0,0,0,0.5);

    }

    #top .header_color .avia-color-theme-color {

    color:rgba(0,0,0,0.5);

    }

    #top .main_color .avia-color-theme-color {

    color:rgba(0,0,0,0.5);

    }

    #top .alternate_color .avia-color-theme-color {

    color:rgba(0,0,0,0.5);

    }

    #top .footer_color .avia-color-theme-color {

    color:rgba(0,0,0,0.5);

    }

    I know you felt like it was pulling teeth but it was a worth while lesson for me. Sorry if you feel exhausted!!

    Cheers & I guess we can shut up shop on this issue finally

    Andy

    #122449

    What’s the setting that controls all of these selectors? anchor (link) highlights? When I turn that color “off” in firebug, we get the color you prefer.

    http://i.imgur.com/f8gWk4K.png

    #122450

    Hi MikehJPP,

    You are looking at the wrong selector.. Look at the h3 tag to see the code

    .main_color .heading-color, .main_color h1, .main_color h2, .main_color h3, .main_color h4, .main_color h5, .main_color h6, .main_color .sidebar .current_page_item > a, .main_color .sidebar .current-menu-item > a, .main_color .pagination .current, .main_color .pagination a:hover, .main_color strong.avia-testimonial-name, .main_color .heading, .main_color .toggle_content strong, .main_color .toggle_content strong a, .main_color .tab_content strong, .main_color .tab_content strong a, .main_color .asc_count, .main_color .avia-testimonial-content strong, .main_color div .news-headline {
    color: #FFCE66;
    }

    —-

    Right now there are 4 blocks of code that control the color of the Home in that image , and here they are from strongest on top to weakest on bottom. (yes this needs to be fixed) i believe.

    .alternate_color .breadcrumb, .alternate_color .breadcrumb a, #top .alternate_color.title_container .main-title, #top .alternate_color.title_container .main-title a {
    color: #EB8A22;
    }
    .alternate_color .heading-color, .alternate_color h1, .alternate_color h2, .alternate_color h3, .alternate_color h4, .alternate_color h5, .alternate_color h6, .alternate_color .sidebar .current_page_item>a, .alternate_color .sidebar .current-menu-item>a, .alternate_color .pagination .current, .alternate_color .pagination a:hover, .alternate_color strong.avia-testimonial-name, .alternate_color .heading, .alternate_color .toggle_content strong, .alternate_color .toggle_content strong a, .alternate_color .tab_content strong, .alternate_color .tab_content strong a, .alternate_color .asc_count, .alternate_color .avia-testimonial-content strong, .alternate_color div .news-headline {
    color: #FFCE66;
    }

    h1 {
    color: #EB8A22 !important;
    }
    .alternate_color, .alternate_color .site-background, .alternate_color .first-quote, .alternate_color .related_image_wrap, .alternate_color .gravatar img .alternate_color .hr_content, .alternate_color .news-thumb, .alternate_color .post-format-icon, .alternate_color .ajax_controlls a, .alternate_color .tweet-text.avatar_no, .alternate_color .big-preview, .alternate_color .toggler, .alternate_color .toggler.activeTitle:hover, .alternate_color #js_sort_items, .alternate_color.inner-entry, .alternate_color .grid-entry-title, .alternate_color .related-format-icon, .grid-entry .alternate_color .avia-arrow, .alternate_color .avia-gallery-big, .alternate_color .avia-gallery-big, .alternate_color .avia-gallery img, .alternate_color .grid-content {
    color: #EB8A22;
    }

    Thanks,

    Nick

    #122451

    I am? I believe what you cited is what I was calling attention to in the picture? Regardless, when I shut that color “off” in firebug in the color of his text reverted to his preference. Fixed?

    Couldn’t he just copy that code, put the color he wants and important, and done?

    Thanks!

    #122452

    .main_color .heading-color, .main_color h1, .main_color h2, .main_color h3, .main_color h4, .main_color h5, .main_color h6, .main_color .sidebar .current_page_item > a, .main_color .sidebar .current-menu-item > a, .main_color .pagination .current, .main_color .pagination a:hover, .main_color strong.avia-testimonial-name, .main_color .heading, .main_color .toggle_content strong, .main_color .toggle_content strong a, .main_color .tab_content strong, .main_color .tab_content strong a, .main_color .asc_count, .main_color .avia-testimonial-content strong, .main_color div .news-headline {

    color: #MYFAVORITECOLOR; !SUPERDUPERIMPORTANT

    }

    #122453

    Hi,

    Please provide a link to your site so I can answer your questions. I also wouldn’t use !SUPERDUPERIMPORTANT since IE8 is not familiar with that syntax.

    Thanks,

    Nick

    #122454

    haha… indeed IE8 would have a problem.

Viewing 30 posts - 1 through 30 (of 30 total)

The topic ‘Rogue Color Layer’ is closed to new replies.