Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #264244

    When using the “black” option in the styling setting you lose the search icon completely site-wide. Do I need to manually edit the icon itself so that it shows up?

    #264395

    Hi kwstearnes!

    Thank you for visiting the support forum!

    We tested this on our end and the search icon is still there. Make sure that you enabled the “Append search icon to main menu” option on Enfold > Header Layout > Extra Elements. Add this on Quick CSS or custom.css to change the search icon color:

    #menu-item-search a {
    color: red !important;
    }

    Best regards,
    Ismael

    #264482

    This is for Propulsion not Enfold though. I can give you the login to my site so you can see what I am talking about because the only options regarding color I had changed were for the predefined color scheme under Propulsion Theme Option > Layout and Styling > Select a predefined color scheme > Black.

    The box to the right of the text field for the search box is solid black not showing the icon inside when you click on the Blog in the menu at the top…

    but with the Blog set to show on the Welcome page in the Template builder it shows as the cyan.

    I want that box with the icon to be black but the icon needs to be a gray or white or something to show up though. Thanks again.

    #264928

    Hi!

    Please add following code to Quick CSS in Propulsion theme options under Styling tab

    #searchsubmit {
    background-image: url(../images/layout/icon-magnify.png);
    }

    Regards,
    Yigit

    #264963

    Did that but basically the same thing is still wrong except the magnifying glass on the cyan box is now missing.

    #265572

    Hey!

    Please add following code to Quick CSS as well

     div .button:hover, input[type="submit"]:hover  { background-color: #888; }

    Regards,
    Yigit

    #266930

    Nope, that didn’t work either. I may just remove the search box for now, but down the road when my site begins to fill up with content it might become more of a concern to have fixed. Thanks for trying, but if you happen to figure it out let me know. Thanks.

    #266940

    Hi!

    Try adding this code:

    #searchsubmit {
    background-image: url(http://sturnz.com/wp-content/themes/propulsion/images/layout/icon-magnify.png);
    }

    You’ll need to edit this file though, make it transparent.

    Edit: you don’t need to, Yigit already made it for you :)

    Best regards,
    Josue

    • This reply was modified 4 months, 2 weeks ago by  Josue.
    #266943

    Hey!

    Magnify icon used in the theme is an image therefore we cannot change its color using custom CSS. I have edited the icon and change the color. Please download it from here – https://www.dropbox.com/s/suogw5y5gg3nr5x/icon-search.png
    and replace in Propulsion/images/layout
    Cheers!
    Yigit

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.