Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #14560

    hey,

    i’m a professional video editor and want to use this theme for showing my work.

    i have a few questions

    1. the self hosted video i embed is not working on my galaxy s2 (iphone the same) (ogv, webm, mp4, flv), whats wrong?

    when i open the files directly from my server the phone plays all files correctly.

    vimeo links working.

    2. i don’t want to have the video play in the portfolio overview, but how? :)

    3. sometimes i need more than video in a row is it possible?

    4. in the post the video has a thumb. click the thumb the video players show, than you can make play. is it possible to autoplay?

    thankx

    #83969

    hey,

    most of the problems i solved.

    i used the adobe media encoder and the files was not working. now i use the ffmpeg library for encoding. works perfect.

    the *.webm video don’t have to be on the server.

    and the thumbs must have the same size as the video, in my case.

    but one problem i have:

    when i click on the thumb from the video (in single page view) the player shows the first frame of the video.

    is it possible to play the video directly after clicking the thumb (in single page view)?

    sorry for my english :)

    thanxs

    #83970

    Hi Waldspinne,

    Can you link to an example of what is happening now when you click on a video. I’m not sure what you mean with the video showing the first frame only.

    Thanks,

    Devin

    #83971

    hello,

    the link is: http://www.filmfriseur.de/work/

    when you click on a thumb the bigger preview image with the play symbol opened. that’s fine.

    then you click on it and it shows the player and then you have to click start. i would like to click on the thumb with the play symbol and the film starts. with vimeo videos it is working fine. you can see it when you click on “floating”.

    i hope you understand me :)

    i have 5 more questions:

    - most of the time i use firefox 14.01. the player for self hosted videos don’t show the button “fullscreen”. but when i make the browser window very small it show’s the button. do you know why?

    - with chrome and firefox sometimes the portfolio page loads, sometimes not and the load time for the first page is very very long. maybe you can look at my old page under http://www.filmfriseur.de the preview images loads very fast in every browser, this i like :)

    interesting is that sometimes i cant click on any thumb only the videos in the blog (i like – button) are working.

    - when i have a very long description for my work it shows the hole text and not the ‘read more’ link. you can see when you click on “Wer gab Euch das Recht zu morden?” can you explain this for me?

    Maybe most of the issues are generated by the video player, is it possible to change, maybe the jw-player is working better?

    - i have a protected portfolio entry “Connect 2011″ but with the 4 column overview the pass protection is not working!

    and the last one

    - is it possible to sort the portfolio categories? now it is alphabetical and i have to use numbers, i don’t like.

    Thank you very much for your help :)

    #83972

    ok,

    the error with the pass protection for portfolio items is not an error :)

    but all my other problems still exist.

    is it right that the browser pre-loads every video from the landing page before you click a thumb and not only the thumbs?

    thank you

    #83973

    Hi Waldspinne,

    I think a lot of the errors may be the result of a slow server combined with a lot of data trying to be loaded into the page at once. I’m not 100% sure but yes I do believe that when you initially load the page the .mp4 video’s are attempting to pre-load into the page completely.

    I’m not as familiar with the inner workings of the self hosted video so I’m tagging Kriesi as well as another of the support crew to take a look and see what the best course of action is.

    Regards,

    Devin

    #83974

    Hey Devin,

    the webserver can’t be the reason, because its completly new.

    what’s up with the other errors?

    thank you

    #83975

    Hello ? Is anybody out there?

    I have so many questions and no answer :(

    #83976

    Hi Waldspinne,

    I apologize for taking so long to reply and having to make you wait, the fault is entirely mine.

    Before I get to your questions, let me just begin by saying that using Vimeo to host your videos, is the best option you can make for a number of reasons. When your site begins to receive traffic, streaming those videos will eat your bandwidth very quickly besides slowing down your site significantly especially with 18 other sites on your server.

    You wrote something about slow streaming from locally hosted videos, and this is just the beginning. Everybody is slowly migrating to Youtube or Vimeo, so instead of doing that next year it would be much easier to start the new site off on the right foot. (Sorry for the lecture, but it had to be said).

    On that note,

    1) Please check on your server, if .htaccess file exists at the root of your website. There should be one, so please look inside for the lines below, and if not present, please add them (dont add in between open <IfModule and closing </IfModule). Please use a text editor to open the file.

    # Video
    AddType video/ogg ogv
    AddType video/mp4 mp4 m4v
    AddType video/webm webm

    Save the .htaccess file.

    2. From what I see the problem is that on homepage, there are at least 6 files ( itservices.mp4, xeo.mp4, 7tage.mp4, gans.mp4, dlan.mp4, seviceakademie.mp4) which are towards the bottom of the page, and are located where the image ‘cover photo’ is located on previous videos on the upper portion of the page. This causes the videos to immediately load.

    I am testing this now localy to see who the culprit is. Please hang on.

    Thanks,

    Nick

    #83977

    hello nick,

    i like vimeo too. but my old homepage was loading very fast and the streaming performance on my server was very good.

    maybe you will have a look http://www.filmfriseur.de/blog

    i already edited the .htaccess file because i read it in the documentation.

    now i change the “Slideshow behavior on overview pages” settings in the theme options to “..display only single image on overview pages and all slideshow images except the first one on single entries” and set the first item in the slideshow to a jpg file to have no video loading on the overview page. but it is not faster now. with internet explorer it is a little bit better than with firefox 14.01. it seems that the problem is the sortable creteria from the portfolio items. what is your opinion?

    all my other problems stills exist and i found one more:

    when you make the browser windows very small, like on smartphones and show the single entries the menue with prev, next and close is over the creteria menue from the portfolio items. in my case “All / 01_…. / 02_… / 03_… / 04_…” so you can not click on it.

    sorry for my english,

    i hope that you can help me

    thanks a lot

    #83978

    Hi Waldspinne,

    I’m getting a good solid page load now that you have added in the single images instead of the straight video’s themselves. Everything on the first visit to the site with a cleared cache is loading in at just under 3 seconds.

    I only loaded up a single video but streaming didn’t give me any difficulties.

    For the layout issues, we’ll need to create some new media query rules. Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    @media only screen and (min-width: 480px) and (max-width: 767px) {
    #js_sort_items {margin-bottom: 60px;}
    }
    @media only screen and (max-width: 479px) {
    #js_sort_items {margin-bottom: 60px;}
    }

    Regards,

    Devin

    #83979

    hello devin,

    the new rules are not working, the layout issue is still the same.

    but i am happy that the page is loading fast. do you also test it with firefox?

    thanks

    #83980

    I don’t see the new css in either your custom.css file here: http://www.filmfriseur.de/work/wp-content/themes/angular/css/custom.css or loaded into the page via Quick CSS.

    Can you double check that you’ve uploaded the file or added the css to your Quick CSS?

    Regards,

    Devin

    #83981

    OK, i am sorry it was my mistake, it works ;)

    i don’t clear the cache before testing…

    thanks a lot.

    what’s up with nick? can he help me with my other questions?

    #83982

    Which issues specifically are you still having trouble with? It’ll help to re-define where we are at with the fixes :)

    Regards,

    Devin

    #83983

    1. when you click on a thumb the bigger preview image with the play symbol opened. that’s fine.

    then you click on it and it shows the player and then you have to click start. i would like to click on the thumb with the play symbol and the film starts. with vimeo videos it is working fine. you can see it when you click on “floating”.

    i hope you understand me :)

    2. most of the time i use firefox 14.01. the player for self hosted videos don’t show the button “fullscreen”. but when i make the browser window very small it show’s the button. do you know why?

    3. when i have a very long description for my work it shows the hole text and not the ‘read more’ link. you can see when you click on “Wer gab Euch das Recht zu morden?” can you explain this for me?

    #83984

    Hi,

    Sorry for the delay. My laptop dies when it tries to load 6 of your movies simultaneously. I am back at the desktop and thought of a few things to test.

    ..sortable criteria.(your hypothesis in an earlier message)..Its most likely an issue with local storage and the manner in which the local files are accessed, or the path is being referenced in the code. this is a real solid sorting app, it would be surprising that a bug is behind it all,

    This is the first thing I want to look at, because there is a point in the sequence of the portfolio items when they start to automatically load instead of waiting as the 1/2 do. I am waiting on results of speed test i just ran, a bit of a queue, because yesterday the waterfall view of the speed test immediately showed the place where problems began, be nice to sort and run the test on the sorted portfolio to compare. you can look test it yourself ->http://www.webpagetest.org/compare .

    But don’t worry, we will all get to the bottom of this and solve it before midnight your time i am willing to bet.

    Thanks,

    NIck

    #83985

    Hi,

    I dont know what you did, but the page loads now without triggering the movies to start loading. The other three issues you had:

    1) The player was created with a ‘safety shutter’ to prevent sites like youtube from automatically loading a video along with the page. This way the visitor to your website would not automatically be forced to watch a video. The css class is called slideshow_overlay , and it’s quite difficult to remove.

    2) I tested with 5 browsers including the latest firebox and every one of them shows the full screen button. Try updating your Flash.

    3) I think that is how the website is built, because I don’t see a page which shows a ‘read more’ link when there is a lot of text. This is something you can easily make yourself though. Here are instructions, and will take 10mins (http://plugins.learningjquery.com/expander/demo/index.html)

    Good luck!

    Nick

    #83986

    OK,

    I don’t know if i understand the instructions for this query thing but i will have a look :)

    I would like to have it like in the demo of the angular theme (the read more button)

    my flash is up to date. do you tested with differnt browser sizes?

    I like the new theme too. is it possible to have the same hover effect in the angular theme?

    Thank you all.

    #83987

    Hi,

    Ahh, I understand now. Mistake all mine. I was looking at your other link you posted before, but the wrong one, so was confused.

    To get the ‘more link’, that is a short code. So when you write a post and want to include ‘more’, you go into HTML view and you paste: <!–more–>, see below. That will create the same link as in demo

    first paragraph
    <!--more-->
    second paragraph
    third paragraph

    The other items are outside the scope of the support team since they are customizations and require a very large investment of time to accomplish..

    Good Luck,

    Nick

    #83988

    Cool,

    now my last question:

    where can i change the wording “read more” ?

    and then i will be really happy and maybe you too :)

    #83989

    Hey!

    Open up includes/format-standard.php and search for following line:

    the_content(__('Read more  &rarr;','avia_framework'));

    Replace read more with your custom text.

    Regards,

    Peter

    #83990

    Hi,

    Keep asking until your site is how you want it to be and we will do our best to answer. This weekend I will take a look at the issue about the requirement of double clicking the movie prior to its start on my own free time and let you know if there is a way to get around it for self hosted videos.

    Thanks,

    Nick

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘self hosted video’ is closed to new replies.