Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6401

    Starting to work on the SEO for the site, and running into some unusual problems.

    1. The site title for the mainpage is displayed on the top of the browser as: Site TitleSite Title (name is doubled up, repeated twice).

    In trying to fix this, I left the Site Name in the General Setting page blank, but the site title still shows as: Site TitleSite Title

    I have Yoast WordPress SEO activated, but different adjustments in that admin do not an effect on the problem above.

    How do I fix the doubled up title? Where?

    2. Is there anywhere in the admin panel or Yoast WP SEO that I can set the site temporarily to <b>noindex</b>?

    Thank you.

    #54014

    System corrected the problem by itself after a half hour. Weird.

    #54015

    Good to see it solved :) Might I add that this was likely to be a plugin problem, when issues like this happen you can try disabling your plugins to see if this helps :)

    #54016

    The problem was in the Yoast WP SEO plugin settings. At the top of the TITLES configuration page are either suggested title tag code revision or a checkbox to force rewrite of the titles according to Yoast WP SEO settings. After I checked the Force Rewrite setting, everything I did within Yoast made sense when the actual titles were generated. By observation, trial and error you easily figure out how to get the SEO optimized titles you want for each page. This is the plugin recommended by Dude.

    #54017

    Thanks for letting us know :) It’s a great plugin indeed.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘SEO doubled title? How to fix?’ is closed to new replies.