Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #26564

    Hello,

    Since using enfold as my theme and making my website live the SEO doesn’t seem to list or index the frontpage(homepage) and only indexes the contact page?

    http://www.happREMOVEyvalleREMOVEyfoundation.com/

    Please remove the 2 REMOVE above to get the correct address, just don’t want Google to index this when it’s not indexing my other pages lol..

    I did notice it indexed:

    http://www.happREMOVEyvalleREMOVEyfoundation.com/homepage/feed and I thought maybe that’s causing duplicate content and not indexing the homepage? So I used Google Webmaster Tools to remove the three following:

    homepage/feed/

    wp-content/themes/toggleway/config-layerslider/LayerSlider/skins/

    wp-content/themes/toggleway/framework/

    After doing that all my www. indexes were removed?

    As you can see by doing the: site:www.happREMOVEyvalleREMOVEyfoundation.com/ in Google.

    If you do the same without the www. you will see it only shows the contact page and some other random pages..

    I would really appreciate help on this as I want to start purchasing this theme for all my future projects, however I want to make sure the index and SEO is sorted.

    In short why won’t ‘home’ index but contact does? I’ve checked everything I can think of.. it has follow, index etc.. the sitemap seems fine.. bing.com shows the homepage.. except for the fact it shows the http:// and not the http://www. I want all my pages to be http://www and not http:// in all searches. I can give you admin access for both cpanel and wordpress if required.

    I know SEO isn’t properly a big deal in these forums but if you help me you’ll be enabling a valued customer to keep giving you money for future projects ;) It’s a good investment :P

    Cheers,

    Daniel

    #130848

    Tbh I don’t think this is issue is theme related. I just found one occurrence of “http://happREMOVEyvalleREMOVEyfoundation.com/” in the source code which points to an image:

    <img class='avia_image avia-builder-el-4 el_after_av_hr avia-builder-el-last avia-align-left ' src='http://happREMOVEyvalleREMOVEyfoundation.com/wp-content/uploads/Ping-Fred-487x430.jpg' alt='' title='' />
    Maybe you changed the blog url in the past and some “hardcoded” urls in the database still point to “http://happREMOVEyvalleREMOVEyfoundation.com/” instead of “http://www.happREMOVEyvalleREMOVEyfoundation.com/”. You can use: WP MIGRATE DB to replace all occurrences of “http://happREMOVEyvalleREMOVEyfoundation.com/” with “http://www.happREMOVEyvalleREMOVEyfoundation.com/” and to export the database with the new paths. Then delete your old database and import the new database file which was generated by WP MIGRATE DB.

    #130849

    Hello Dude,

    Thanks for the reply, so you think one instance of http:// and not all being http://www. can cause the frontpage not to rank?

    Cheers for the WP MIGRATE DB plugin suggestion I’ll have to keep that in mind.

    But in theory a homepage with index, follow should index correct? Only reason I’m thinking is maybe duplicate data? Because if you add /feed to a page or even /homepage/feed to the main page it’ll still show the main page or whatever is before feed. Any thoughts on this?

    Thanks,
    Daniel

    #130850

    I don’t think it’s caused by duplicate content. Did you try to generate a sitemap? I’d suggest to use Yoast SEO: http://wordpress.org/plugins/wordpress-seo/ but if you’re using another seo plugin you can also try http://wordpress.org/plugins/google-sitemap-plugin/

    Then go to the Google Webmaster tools and submit the sitemap.xml. This will “force” google to re-index all pages which are listed in the sitemap.xml.

    #130851

    Yeah I started out by Yoast SEO and it didn’t seem to list the pages, so I thought that was the initial problem so I went back to the SEO plugin I always use that works: All In One SEO Pack I also use the plugin: Google XML Sitemaps. I’ve added both the http:// and the http://www and done the prefer settings to www. and submitted the Sitemap a few times, now it says Submitted 23 pages, but has a – (dash) next to Indexed. Maybe it’ll take awhile? Usually it’s indexed in a few days when the site is new and I don’t even use webmaster tools. I guess I’ll just have to wait 2-4 weeks and hope for the best? lol I just hope I have set it up or I’ll be waiting more time after this time if you get me.

    Just making sure that other sites that use Enfold are indexing their root page (homepage) correctly?

    Thanks again!

    #130852

    Yes, I’m not aware of any indexing issues.

    I’d also recommend to deactivate directory listing – then google won’t create/show search results like “Index of /wp-content/themes/toggleway/framework/php”, etc. – many web hoster allow you to switch directory listing on/off with the cpanel or on the administration page. If not try to use the htaccess file: http://viralpatel.net/blogs/htaccess-directory-listing-enable-disable-allow-deny-prevent-htaccess-directory-listing/

    #130853

    Awesome! Will Google remove those links once it re-crawls it a few times? I’ve done as you suggested.

    Ok, perhaps I setup Yoast SEO incorrectly at first on this website, I’ll just wait a few weeks and see how things go. If no luck I’ll try a place like http://ineedhits.com/ or someone, maybe you have one in mind or do you do everything yourself?

    Cheers,

    Daniel

    #130854

    Hi!

    Yes, I they’ll remove invalid links from the search results but it can take some time. Yes, we do everything on our own when it comes to SEO.

    Regards,

    Peter

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘SEO Issue’ is closed to new replies.