Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #210396

    When I try to set a Featured Image for a product, it goes away once I press ‘Update’.

    It’s the same problem as this thread:

    However, both WordPress and Flashlight are updated to the latest versions. I’m running the Enfold theme on another site, but it doesn’t have the same problem with the same version of WordPress.


    Hi SSWD!

    The featured image has been disabled for Flashlight. How did you add a featured image? If you want to show the featured image on the editor, edit functions.php then find this code on line 162:

    //add thumbnail support only for frontend so the user doesnt see the backend interface which gets automatically populated by the theme
    //remove post thumbnails from page and posts
    //remove post thumbnails from pages, posts and various custom post types
    	add_theme_support( 'post-thumbnails' );
    	add_action('posts_selection', 'avia_remove_post_thumbnails');
    	add_action('init', 'avia_remove_post_thumbnails');
    	function avia_remove_post_thumbnails($msg)
    		global $post_type;
    		$remove_when = array('post','page','portfolio');
    			foreach($remove_when as $remove)
    				if($post_type == $remove || (isset($_GET['post_type']) && $_GET['post_type'] == $remove)) { remove_theme_support( 'post-thumbnails' ); };
    		return $msg;

    You can remove it.



    Hi Ismael,

    I have removed this code but the product feature image still cannot update/show.
    But when I change to other templates, it works good on this.
    May you take a look of this?

    Thank you!




    You need to add or set the featured image on the gallery options. The theme does not use the wordpress post thumbnail for the featured image.


Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Set Featured Image doesn't work for Products’ is closed to new replies.