Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7352

    I’m sure this has been answered somewhere here before, but my search didn’t find a solution that has worked for my site. I’ve created a page that I want to use as the home page, but setting it as the front page under the BroadScope theme options just produces a page with a header and main nav and a large blank area below that. Using the WordPress reading settings to set any page as the static home page makes it use the blog page no matter what. Any ideas?

    #57614

    Hi,

    I’m not sure what’s going on but I’ll just tell you how I achieve the wanted effect. I create a page and fill it with content, then I apply the wanted page template to it (at the right) – after which I publish the page. Then, I go into the theme options and set is as my frontpage.

    If this doesn’t work for you, maybe you can create me an admin account and send me the info to (Email address hidden if logged out) and I’ll look into it – be sure to provide enough information.

    #57615

    I’ve set up the page I want to use as the home page. (http://www.test.soptv.org/southern-oregon-public-television-soptv/) I’ve set that as the front page under frontpage settings. Still, when I go to the root directory (http://www.test.soptv.org/), I get nothing. If I go to the WordPress settings under Reading and set any page at all as the static home page–including the one I want–the root directory turns into the blog page. It’s very annoying.

    If no one else has any suggestions and I can’t work it our on my own, then I may take you up on your very generous offer. Thanks.

    #57616

    I replied to your mail :)

    #57617

    Just to update anyone else that might be searching for the solution to this same problem, I was on the wrong testing server. The PHP on that server was version 5.1.6 and therefore only supported WordPress up to version 3.0.2. As soon as I migrated over to the correct testing server with newer PHP and WP, it worked just fine. The WordPress Reading setting doesn’t have to be changed to a static page. The Frontpage setting for BroadScope works fine all by itself.

    And Chris Beard deserves a special thank you for going above and beyond to try and help me out. Thanks, Chris.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Setting Home Page Problem’ is closed to new replies.