Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #171331

    Hi there…

    I’ve researched the forum and am not able to find anything current to answer my question.

    There seems to be an issue with the shopping cart icon in the top menu bar working in real time.
    – When products are added, the value in the cart remains at $0 until you go to another page.
    – Once the cart has something in the card it seems to populate in real time, however,
    – if you go to the shopping cart and remove items from the cart, without removing all of the items, the icon in the menu header totals $0.

    Thank you in advance for your help.


    Hello jeanburk01!

    I can’t reproduce the first issue – the cart seems to work perfectly fine on my end:

    However I can reproduce the second issue and I think I found the problem – the ajax cart widget (which we use to fetch the subtotal value) does not work on the cart page and always returns 0. Thus we need to deactivate our js function on this page. You won’t notice it anyway because WooCommerce always reloads the page after the user clicked on the “remove product” button. Try to replace following code in /wp-content/themes/propulsion/config-woocommerce/woocommerce-mod.js

            setTimeout(first_load_amount, 10);
            $('body').on('added_to_cart', update_cart_dropdown);


            setTimeout(first_load_amount, 10);
            $('body').on('added_to_cart', update_cart_dropdown);



    Hi Peter!

    Ich habe die selbe Herausforderung. Den Code habe ich, wie oben, ersetzt. Keine Veränderung.

    Ist es möglich, dass die “0” oder “0,00” Warenkorb Anzeige damit zusammenhängt? Siehe Film:



    Versuche einmal folgende Zeile

    setTimeout(first_load_amount, 10);


    //setTimeout(first_load_amount, 10);

    zu ersetzen.



    Hi Peter!

    Super! Jetzt funktioniert es! Vielen Dank!

    BTW eine kleine Sache wäre da noch. Habe das schon in einem eigenen Beitrag gepostet.
    Vermute aber mein Englisch ist zu konfus;)

    Das Warenkorb Widget (wenn Produkte drin sind) “verschwindet” unter dem “Suchformular” und/oder dem Slider-Bildern.
    Auf den “Shop Seiten” (Shop, Produkte etc.) funktioniert es.

    Auf der Startseite, Blog oder in diesem Fall “Warenkorb” rutsch es darunter.

    cart widget


    Just4Info. Thema erledigt.
    Moderator Ismael hat mir soeben zur Lösung verholfen
    `#main {
    z-index: 1;
    position: relative;

    #shop_header {
    z-index: 9999;
    position: relative;
    LG, Kim

    • This reply was modified 2 years, 1 month ago by  KimiO.


    Sehr gut :)


Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Shopping Cart Update’ is closed to new replies.