Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #311423

    Hi,

    I have am using the layout builder to create a page.
    On that page I have an opening shortcode in a “code block” and it works.
    At the bottom of the page I have the closing shortcode in another “code block” but it won’t work.
    All it does is display the shortcode [/pc-pvt-content]

    How can I get the closing shortcode to render properly??

    Thanks,

    Mitch

    #311424
    This reply has been marked as private.
    #311876

    Hi!

    I have created a private page called “Test page” and duplicated your page. Then removed the bottom Code block element and it seems like it did not break the layout. Please review “Test page” and remove second code block from your original page.

    Best regards,
    Yigit

    #312019

    Actually I NEED the closing shortcode.
    That is the problem.
    The layout builder works fine except it WILL NOT render the closing shortcode.

    #313206

    Hi!

    You’d need to put both the opening and closing shortcodes inside one code block element.

    Cheers!
    Josue

    #313459

    I don’t understand how it can render the code fine in the first block without the closing tag and why it can’t render the code in the second block?

    This seems to be a flaw.

    And I can’t put it in one block.
    It needs to wrap around the content.

    #313566

    Hi Mitch!

    The code element is not meant to be used that way. Have you tried using Text Blocks instead? or building the page without the Layout Builder (using Magic Wand shortcodes), that way you can freely put your custom shortcode wherever you want in the content.

    Regards,
    Josue

    #313611

    Hi Josue,

    I did try a Text Block … but that didn’t work either.

    If I go back to the normal editor it doesn’t help.
    And, the normal editor might work for you or me, but not for a client – lol

    It must have something to do with using a shortcode to wrap around more shortcodes around more shortcodes that is messing it up :-(

    Thanks for your help though!!

    Mitch

    PS – thanks for keeping your theme up-to-date!!! WP 4.0 is out and Enfold is good to go!! Keep up the updates/upgrades. It makes it easy to recommend you to clients!!!

    *********CLOSED**********

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Shortcode issue’ is closed to new replies.