Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11214

    Help someone?

    I have an issue with the footer on all my pages on my site http://www.chattybrain.com. I’ve tried various options, adding more, less, no widgets but nothing seems to work. Generally everything seems to go in to one column. Ideas to solve this please?

    #70980

    Hey,

    DId you set the number of footer columns in the Theme Options panel first (Header & Footer section)?

    Then you have to add the widgets in the widgets control panel.

    I noticed the “one_half” column shortcode div was active in your footer. I’m not sure if that is normal, but it could be why your footer is defaulting to one column. I don’t know how it got in there though!

    Do you have any plugins active? You could try disabling them and see if it helps.

    rich

    #70981

    Hi … thanks for the response. I did activate the footer number in the theme option and then added widgets accordingly. To give you an idea, if you look at my site now, it is set to three columns with the following widgets:

    – Column one: Categories

    – Column two: Pages

    – Column three: Blog Roll

    One and two seem to be fine, but three just goes under one ?!?!

    I also went through all my plugins (not that many) and disactivated or deleted anything I was not using. You mention the shortcode which is interesting. I am not too sure about those as am just learning shortcodes, how would I manipulate that if you think that is the issue?

    Thanks

    Angelina

    #70982

    Hey!

    Hmmm. Now you have two columns working, but the third one is skewed. Did you change the footer.php file at any stage, accidentally or otherwise? Sometimes if you let one semi-colon or parenthesis go astray it messes things right up!

    The shortcode thing I mentioned is ok. It’s what the theme uses to set the columns. In this case its an internal thing, not one that you have set, but they work the same way.

    rich

    #70983

    Ok I am now completely stumped! I thought you might have been on to something with the fact that I made a small change to the footer when I removed the credits (WordPress Theme by Kriesi.at) thinking I might have taken out more code then needed.

    So I went back to the original footer.php file and re-uploaded the untouched code.

    I’ve left it online right now so you and the rest of the support can see that the problem still persists. The third column is still aligning itself under the second one.

    HELP PLS – thi sis driving me bonkers.

    Cheers

    #70984

    Hey Angelina,

    Well that looks the same as the one before. So it can’t be the footer.php unless there is something wrong with that one. That’s the file that controls the footer of the site. Did you change any other .php files?

    It’s hard to know what’s wrong from out here. If one of the support guys doesn’t come by, you could try making me a user and I can have a look from inside the site. Send me the log/pass here: (Email address hidden if logged out)

    rich

    #70985

    Did you install a plugin called Ultimate-Tinymce or something? I think it might be affecting the column widths of the shoutbox theme. That is why the third column is being positioned under the first – there isn’t enough width in the footer so it is being displaced downwards.

    If you cheat the column widths by playing with the margin values of the css for the footer you can correct it. But there is an underlying problem which I think is that plugin.

    rich

    #70986

    Rich… you are absolutely right… it was Ultimate-Tinyymce. I just uninstalled it and it is now fine. (btw how did you figure that one out?)

    I’ll try playing around with the footer width in the css as you say and see if that helps. Hopefully it will not mess up the theme.

    As you say, maybe one of the support ppl will come by this thread and have some other suggestions. For now thanks a million for the quick fix.

    Angelina

    #70987

    I saw it checking your site with Firebug (Firefox add on – its very useful). Tinymce css sets the column widths for a three column layout to 30.66%. It should be 30% for Shoutbox. if you localise your css changes just to the footer you shouldn’t have any problems with the rest of the theme.

    Your footer seems to be okay now. Did you adjust the css or turn off Tinymce (or both)?

    If you need Tinymce to run you could try adding something like this to your custom css:

    #footer .one_third {width: 30% ! important;}

    Hopefully that will work, I’m not so hot on css!

    #70988

    Hi Angelina,

    If you’d like to enable the plugin again, just from reading the description its probably fixable with a short bit of css. The snippet from rumblefish might work, but I can’t say for sure without actually having seen it running live :)

    Regards,

    Devin

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Shoutbox: Problem with footer alignment on all pages’ is closed to new replies.