Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #18086

    Hi folks,

    I would like to show post comments directly in blog index. It’s work perfectly in single post, but not in blog page (posts list). I tried everything I knew, but nothing worked. The page is http://www.estudioteca.com/blog

    Can you help me?

    PS. I’m using Facebook plugin. It changes the WordPress comments to FB comments.

    #98178

    Hi, I’m having the same issue. Comments show up when I view the individual posts. But, I’ve created a blog page on our temporary site ( http://www.withthisring-false.info/gems ) and it won’t show up at the bottom there. I’d like comments to show up for each blog post as we add them. Thanks!

    #98179

    Hi,

    Open page.php, find this code

    $avia_config['size'] = 'page';
    get_template_part( 'includes/loop', 'page' );

    Replace it with:

    $avia_config['size'] = 'page';
    get_template_part( 'includes/loop', 'page' );

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    You turn the comment box on and off. Edit the page, look for Screen Options and checked the Discussion. Check the “Allow Comments” option to enable comments.

    Regards,

    Ismael

    #98180

    I didn’t find that code exactly in page.php, but found this:

    $avia_config = avia_layout_class( ‘main’ , false) == ‘entry_without_sidebar’ ? ” : ‘entry_with_sidebar';

    get_template_part( ‘includes/loop’, ‘page’ );

    ?>

    Is this the right code? If so, please advise how to tweak. Thanks!

    #98181

    Hi,

    @imagestudios: This is Angular topic, I think you have Enfold. Yes, that is the same.

    Find this code

    $avia_config['size'] = avia_layout_class( 'main' , false) == 'entry_without_sidebar' ? '' : 'entry_with_sidebar';
    get_template_part( 'includes/loop', 'page' );

    Replace it with:

    $avia_config['size'] = avia_layout_class( 'main' , false) == 'entry_without_sidebar' ? '' : 'entry_with_sidebar';
    get_template_part( 'includes/loop', 'page' );

    //wordpress function that loads the comments template "comments.php"
    comments_template( '/includes/comments.php');

    Regards,

    Ismael

    #98182

    Hmm, didn’t work. I’m sure I’m missing something. Here’s the page I’m trying to get comments to appear on: http://withthisring-false.info/gems/

    #98183

    Hi,

    You need to edit that page, look for Screen Options > check the Discussion option then “Allow Comments”.

    Regards,

    Ismael

    #98184

    Did that ( http://withthisring-false.info/screenshot ), but still no comments area showing on the page. I also noticed that the Sharing Buttons weren’t showing on this page if that helps. Thanks for helping me sleuth this out.

    #98185

    Hi imagestudios,

    Anything that is created with the Advanced Layout editor wont show comments as far as I know. You would need to use the regular visual editor because of the way the page gets output on the front end.

    Regards,

    Devin

    #98186

    OK, will give that a shot. Thanks.

    #98187

    That worked, but odd it can’t show using the Advanced Layout Editor. Thanks again for your help.

    #98188

    Hi,

    Please follow my directions here ( http://www.kriesi.at/support/topic/comments-dont-show-up-on-portfolio-pages#post-117921 ) to get comments working with Portfolio items and elsewhere


    You are using a very old version of the theme. v1.31 , while 1.6 is out with lots of fixes and overall improvements. Please download it from themeforest.net but please be aware that it will overwrite all your theme files.

    There is a video tutorial by Devin on how to go about updating with ftp https://vimeo.com/channels/aviathemes/64927356

    Thanks,

    Nick

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Show comments in blog index’ is closed to new replies.