Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #5607

    Hi, i’ve read previous users with this issue and i cant seem to figure out what happened here.

    I reverted my Index, sidebar and footer php files and still having the issues, i ran the w3c validator but cant quite make out what any of it means as far as fixing the issue.

    the site is clearviewglobal.com.previewdns.com, click any article in the blog section

    thanks in advanced

    #51064

    Hey,

    you need to remove some code. I think in footer.php you need to remove:

    <body class="yui-skin-sam">

    and:

    </body>
    </body>

    #51065

    Greatness!

    the footer.php had one </body> at the bottom. (though this was an untouched original i had reverted to)

    This alone has resolved the issue. thanks

    #51066

    oops. actually, it does not work. weird it did for a sec, then i cleared my cache and temp and it no longer works. makes no sense. any other ideas ?

    #51067

    Here is my Single.php

    <?php get_header(); ?>

    <div id="content" class="bg_sidebar">
    <div id="inner_content">

    <?php if (have_posts()) : while (have_posts()) : the_post();
    $punchline = get_post_meta($post->ID, "punchline", true);
    $portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    ?>

    <div class="entry">

    <span class="meta"><?php echo $punchline; ?></span>
    <h2 id="post-<?php the_ID(); ?>"><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    <div class="entry-head">
    <span class="categories"><?php the_category(', ') ?></span>
    <span class="date">on <?php the_time('F jS, Y') ?></span>
    <span class="comments"><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?><?php edit_post_link('Edit', ' ,', ''); ?></span>
    </div>

    <div class="entry-content">
    <?php
    if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
    ?>
    <?php the_content("Read more »"); ?>
    </div><!--end entry-content-->
    <?php the_tags( '<p class="meta">Tags: ', ', ', '</p>'); ?>
    </div><!--end entry-->
    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    <?php endwhile; else: ?>
    <div class="entry">
    <h2>Nothing Found</h2>
    <p>Sorry, no posts matched your criteria.</p>
    </div>

    <!--do not delete-->
    <?php endif; ?>
    </div><!-- end inner_content-->

    <?php get_sidebar(); ?>

    </div><!-- end content-->
    <?php get_footer(); ?>

    #51068

    Here is my Footer.php

    </div><!--end main-->

    <div id="footer">
    <span class="copyright"><strong>Copyright &copy;</strong> <a href="http://www.kriesi.at">Kriesi.at - New Media Design</a> - remove this once purchased ;)</span>
    <span class="scroll-top"><a href="#top">top</a></span>
    </div><!--end footer-->

    </div><!--end top-->
    </div><!--end wrapp_all-->
    <?php wp_footer();
    global $k_options;

    if($k_options['general']['google_analytics'])
    echo $k_options['general']['google_analytics'];
    ?>

    </html>

    #51069

    here is my sidebar.php

    <?php
    global $kriesi_options;
    $themeurl = get_bloginfo('template_url');
    function kriesi_small_description($themeurl)
    {
    echo'
    <div class="small_box">
    <span class="meta">This theme is ready...</span>
    <h3>Widget Ready</h3>
    <p>The text you are currently reading can be added either through sidebar widgets or directly in the sidebar.php file. </p>
    <p>If you add a widget to the predefined widget area this text will be removed automatically.</p>
    <img class="ie6fix" alt="" src="'.$themeurl.'/files/front5.png"/>
    </div><!--end small_box-->';
    }

    function kriesi_small_description2($themeurl)
    {
    echo'
    <div class="small_box">
    <span class="meta">writ a mail or letter</span>
    <h3><a href="#">Contact Us</a></h3>
    <p>If you are interested in using our service feel free to contact us.</p><p>Either by sending a mail to office[at]twicet[dot]com, or by using our jQuery improved ajax contact form ;D</p><img class="ie6fix" alt="" src="'.$themeurl.'/files/front4.png"/>
    </div><!--end small_box-->';
    }

    function kriesi_small_description3($themeurl)
    {
    echo'
    <div class="small_box box1">
    <span class="meta">more for your money</span>
    <h3><a href="#">Multiple Skins</a></h3>
    <p>Twicet comes with multiple Skins to choose from. To make cusomization of existing skins easier the color informations are stored in separated stylesheets.</p><p>Additionally all PSD files that where used to create this theme are included.
    </p><img class="ie6fix" alt="" src="'.$themeurl.'/files/front1.png"/>
    </div>';
    }
    ?>

    <div id="sidebar">
    <?php
    if($post->post_parent)
    $children = wp_list_pages("title_li=&sort_column=menu_order&child_of=".$post->post_parent."&echo=0");
    else
    $children = wp_list_pages("title_li=&sort_column=menu_order&child_of=".$post->ID."&echo=0");
    if ($children) { ?>
    <div class="small_box widget_pages">
    <h3>Sub-Navigation</h3>
    <ul>
    <?php echo $children; ?>
    </ul>
    </div>
    <?php }

    if (is_page()){ #sidebar used for pages
    if (function_exists('dynamic_sidebar') && dynamic_sidebar('Sidebar Pages') ) : else: ?>
    <?php

    kriesi_small_description($themeurl);
    kriesi_small_description2($themeurl);
    ?>
    <div class="widget">
    <?php get_search_form(); ?>
    </div>

    <?php endif;

    }else{ #sidebar used for blog & archives (category, tag, date, etc)

    if (function_exists('dynamic_sidebar') && dynamic_sidebar('Sidebar Blog') ) :else: ?>

    <?php

    kriesi_small_description($themeurl);
    kriesi_small_description3($themeurl);
    kriesi_small_description2($themeurl); ?>

    <div class="widget small_box">
    <?php get_search_form(); ?>
    </div>

    <?php endif; }

    if (function_exists('dynamic_sidebar') && dynamic_sidebar('Sidebar Everywhere') ) : endif;?>
    </div><!-- end sidebar -->

    #51070

    Here is my header.php

    <?php
    global $k_options;
    ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">

    <head profile="http://gmpg.org/xfn/11">
    <link rel="shortcut icon" href="<?php bloginfo('stylesheet_directory'); ?>/favicon.ico" />
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
    <title><?php if (is_home()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?></title>

    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS2 Feed" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/prettyPhoto/css/prettyPhoto.css" type="text/css" media="screen"/>
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />

    <?php if($k_options['general']['whichdesign'] == 5){ ?>
    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/css/style5.css" type="text/css" media="screen" />
    <?php } else if($k_options['general']['whichdesign'] == 4){ ?>
    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/css/style4.css" type="text/css" media="screen" />
    <?php } else if($k_options['general']['whichdesign'] == 3){ ?>
    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/css/style3.css" type="text/css" media="screen" />
    <?php } else if($k_options['general']['whichdesign'] == 2){ ?>
    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/css/style2.css" type="text/css" media="screen" />
    <?php } else {?>
    <link rel="stylesheet" href="<?php echo bloginfo('template_url'); ?>/css/style1.css" type="text/css" media="screen" />
    <?php }

    if ( is_singular() ) wp_enqueue_script( 'comment-reply' );

    if ( ( is_single() || is_page() || is_home() ) && ( !is_paged() ) ) {
    echo '<meta name="robots" content="index, follow" />' . "n";
    } else {
    echo '<meta name="robots" content="noindex, follow" />' . "n";
    }
    wp_head(); ?>

    <meta name="twicet1" content="<?php echo $k_options['mainpage']['autorotate'];?>" />
    <meta name="twicet2" content="<?php echo $k_options['mainpage']['auto_duration']; ?>" />
    <meta name="twicet3" content="<?php echo bloginfo('template_url'); ?>" />
    <meta name="twicet4" content="<?php echo $k_options['general']['whichdesign']; ?>" />
    <meta name="twicet5" content="<?php echo $k_options['mainpage']['ticker_auto_duration']; ?>" />
    <!--[if IE 6]>
    <script type='text/javascript' src='<?php echo get_bloginfo('template_url'); ?>/js/dd_belated_png.js'></script>
    <script>DD_belatedPNG.fix('.ie6fix');</script>
    <![endif]-->

    </head>

    <?php $body_id = is_front_page() ? 'frontpage' : 'subpage'; ?>

    <body id="<?php echo $body_id; ?>">
    <div class="wrap_all">
    <div id="top">
    <div id="head">

    <h1 class='logo'><a href="<?php echo get_settings('home'); ?>/"><?php bloginfo('name'); ?></a></h1>

    <?php wp_nav_menu(array( 'menu' => 'custom_menu',
    'fallback_cb'=> 'kriesi_default_menu',
    'container' => 'div',
    'container_class'=>'navwrap',
    'menu_id' => 'nav'
    )); ?>

    <?php if(!is_front_page() && (class_exists('simple_breadcrumb'))){ $bc = new simple_breadcrumb; }?>

    </div><!-- end head-->

    <div id="main">

    #51071

    i can post anything else you may need or try .

    i can also give you access to wp site manager as it is in the works and not in production, i had planned to go live this morning but this issue has held me back, please let me know how we can work together in this as it is the only issue i have with the site/theme

    #51072

    Hey,

    it seems a div is left unclosed, if you put

    </div>

    right after or right before

    <!-- end inner_content-->

    the sidebar will move to where you want it to be. I’m uncertain if this causes any other problems, if so – let us know.

    #51073

    This singe.php code causes the problem to occur in firefox and IE

    <?php get_header(); ?>

    <div id="content" class="bg_sidebar">
    <div id="inner_content">

    <?php if (have_posts()) : while (have_posts()) : the_post();
    $punchline = get_post_meta($post->ID, "punchline", true);
    $portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    ?>

    <div class="entry">

    <span class="meta"><?php echo $punchline; ?></span>
    <h2 id="post-<?php the_ID(); ?>"><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    <div class="entry-head">
    <span class="categories"><?php the_category(', ') ?></span>
    <span class="date">on <?php the_time('F jS, Y') ?></span>
    <span class="comments"><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?><?php edit_post_link('Edit', ' ,', ''); ?></span>
    </div>

    <div class="entry-content">
    <?php
    if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
    ?>
    <?php the_content("Read more »"); ?>
    </div><!--end entry-content-->
    <?php the_tags( '<p class="meta">Tags: ', ', ', '</p>'); ?>
    </div><!--end entry-->
    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    <?php endwhile; else: ?>
    <div class="entry">
    <h2>Nothing Found</h2>
    <p>Sorry, no posts matched your criteria.</p>
    </div>

    <!--do not delete-->
    <?php endif; ?>
    <!-- end inner_content-->

    <?php get_sidebar(); ?>

    </div><!-- end content-->
    <?php get_footer(); ?>

    #51074

    adding this after the “<!– end inner_content–>” causes it to work in IE but not Firefox

    </div>

    #51075

    !@#

    here, this code works with IE

    <?php get_header(); ?>

    <div id="content" class="bg_sidebar">
    <div id="inner_content">

    <?php if (have_posts()) : while (have_posts()) : the_post();
    $punchline = get_post_meta($post->ID, "punchline", true);
    $portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    ?>

    <div class="entry">

    <span class="meta"><?php echo $punchline; ?></span>
    <h2 id="post-<?php the_ID(); ?>"><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    <div class="entry-head">
    <span class="categories"><?php the_category(', ') ?></span>
    <span class="date">on <?php the_time('F jS, Y') ?></span>
    <span class="comments"><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?><?php edit_post_link('Edit', ' ,', ''); ?></span>
    </div>

    <div class="entry-content">
    <?php
    if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
    ?>
    <?php the_content("Read more »"); ?>
    </div><!--end entry-content-->
    <?php the_tags( '<p class="meta">Tags: ', ', ', '</p>'); ?>
    </div><!--end entry-->
    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    <?php endwhile; else: ?>
    <div class="entry">
    <h2>Nothing Found</h2>
    <p>Sorry, no posts matched your criteria.</p>
    </div>

    <!--do not delete-->
    <?php endif; ?>
    </div>
    <!-- end inner_content-->

    <?php get_sidebar(); ?>

    </div><!-- end content-->
    <?php get_footer(); ?>

    and this code works with Firefox

    <?php get_header(); ?>

    <div id="content" class="bg_sidebar">
    <div id="inner_content">

    <?php if (have_posts()) : while (have_posts()) : the_post();
    $punchline = get_post_meta($post->ID, "punchline", true);
    $portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    ?>

    <div class="entry">

    <span class="meta"><?php echo $punchline; ?></span>
    <h2 id="post-<?php the_ID(); ?>"><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    <div class="entry-head">
    <span class="categories"><?php the_category(', ') ?></span>
    <span class="date">on <?php the_time('F jS, Y') ?></span>
    <span class="comments"><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?><?php edit_post_link('Edit', ' ,', ''); ?></span>
    </div>

    <div class="entry-content">
    <?php
    if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
    ?>
    <?php the_content("Read more »"); ?>
    </div><!--end entry-content-->
    <?php the_tags( '<p class="meta">Tags: ', ', ', '</p>'); ?>
    </div><!--end entry-->
    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    <?php endwhile; else: ?>
    <div class="entry">
    <h2>Nothing Found</h2>
    <p>Sorry, no posts matched your criteria.</p>
    </div>

    <!--do not delete-->
    <?php endif; ?>
    </div>
    <!-- end inner_content-->
    </div>
    <?php get_sidebar(); ?>

    </div><!-- end content-->
    <?php get_footer(); ?>

    i need to find the fix for both to work

    #51076

    Hey!

    I would say we try focusing on the errors that the wc3 validator gets first, this usually fixes all probelems in all browsers ;)

    When I run it I got the following problems:

    you have commented out the home entry in the header.php file. You need to start the comment before the list and close the comment directly afterwards. There is also a problem with a missing div and body tag at the bottom, you might want to fix this as well.

    Once that is done lets check if the problem still occurs.

    By the way: are you running the latest version of the theme? we have had similar issues with a very old version of the Twicet…

    #51077

    Ok, i was getting a lot of errors becuase i was using previewdns.com, i made the site live which resolved 90% of the errors (except the coding errors you listed above)

    So, what i did then…>

    I’ve downloaded the twicet theme from ThemeForest and replaced it completely in my hosting account.

    I disabled all Plugins

    I resolved the missing </Div> issue

    I ran the W3 Validator and it now passes the validation.

    Im still having the same issue.

    After i did this, i did re-enable the plugins (after testing without them) because the site cannot be live without the plugins since i will lose functionalilty.

    So now that the site is live, i really have to get it fixed ASAP.

    Any more ideas?

    by the way, the site is now http://www.clearviewglobal.com since its live

    #51078

    Also, i did uncomment the “Home” link form the header, and that did not help. I then commented it back out after all my testing because i dont want the link there.

    #51079

    Hey! I really dont want to be a pain but the validator still throws various errors. The problem here is that a single unclosed element or wrong nested element can kill the whole site layout so this needs to be resolved before we look further into the issue. I am really sorry for that :/

    #51080

    Not sure what page you validated that you saw errors. But the posts i am having issues with are passing the validation. The home page shows errors on it, they go away when i disable the plugins.

    For example:

    The front page has errors, i disabled the “collision testimonials” plugin and the errors were gone —-did not make a difference for the posts (it has to be something in your template for the posts

    I had errors in “http://clearviewglobal.com/about-us/we-care/”, i disabled the calendar plugin and the errors were gone….did not make a difference for the posts that show the sidebar at the bottom in IE

    get where im going with this?

    I told you before, all pages check out when i disable the plugins, and the posts are still having issues.

    If you need access to my site for you to do your own testing please let me know. i cannot continue having a conversation with you here where i write to you, then you respond 15 hours later, then i reply to you and have to wait another 10-15 hours….This is my business’ site and i need it to work, can we please establish a better means of communications or get you guys a little more responsive or involved

    #51081

    Try

    </div><!-- end content-->
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    #51082

    done deal.

    thanks Chris. that worked on both. just in case anyone has the same problem, here is the final single.php for twicet

    <?php get_header(); ?>

    <div id="content" class="bg_sidebar">
    <div id="inner_content">

    <?php if (have_posts()) : while (have_posts()) : the_post();
    $punchline = get_post_meta($post->ID, "punchline", true);
    $portfolio_image = get_post_meta($post->ID, "portfolio-image", true);
    ?>

    <div class="entry">

    <span class="meta"><?php echo $punchline; ?></span>
    <h2 id="post-<?php the_ID(); ?>"><a href="<?php echo get_permalink() ?>" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></a></h2>

    <div class="entry-head">
    <span class="categories"><?php the_category(', ') ?></span>
    <span class="date">on <?php the_time('F jS, Y') ?></span>
    <span class="comments"><?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?><?php edit_post_link('Edit', ' ,', ''); ?></span>
    </div>

    <div class="entry-content">
    <?php
    if($portfolio_image != "") echo '<img class="aligncenter" src="'.$portfolio_image.'" alt="" />';
    ?>
    <?php the_content("Read more »"); ?>
    </div><!--end entry-content-->
    <?php the_tags( '<p class="meta">Tags: ', ', ', '</p>'); ?>
    </div><!--end entry-->
    <div class='entry commententry'>
    <?php comments_template(); ?>
    </div>

    <?php endwhile; else: ?>
    <div class="entry">
    <h2>Nothing Found</h2>
    <p>Sorry, no posts matched your criteria.</p>
    </div>

    <!--do not delete-->
    <?php endif; ?>
    <!-- end inner_content-->

    </div><!-- end content-->
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    #51083

    Glad I could help :)

    #51084

    I am having similar issues with the latest Twicet downloaded from ThemeForest. The odd thing is, when I am logged out, the sidebar is fine on both the blog page (that lists multiple post), and on the single post view. When I’m logged in however, the sidebar is fine on the blog page but it goes to the bottom of the post when in single post view.

    I’ve tried the final fix posted by clearviewglobal, but it only messes up the page even more (the footer gets pulled upwards into the whitespace).

    Any ideas?

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘sidebar located on bottom of posts (IE)’ is closed to new replies.