Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #181895

    Hello hello,

    I got a problem with the Shop. When having a single product page opened, the sidebar does not appear on the right side, but unter the product image. Seems to be not just css, but some error, and I can´t find it.

    Please see the page. then put a product into the cart, and see the sidebar on the left side below the product image. and below the sidebar starts the description of the product.
    Example of an single product:

    http://sawapet.com/cms/produkt/sawapet-gelenk/

    Just tell me where to look, if it´s too much to hand me out the solution.

    DANKE!

    #182017

    Hi Alemão!

    Please firstly make sure that you are using the latest versions of both Enfold and WooCommerce.
    For a quick guide on updating your theme take a look at this video on updating the Enfold theme via FTP: https://vimeo.com/channels/aviathemes/67209750

    Regards,
    Yigit

    #182173

    He Yigit,

    I have the Theme Version 2.3.2
    WooCommerce 2.0.18
    German Market 2.2.4

    I checked for updates, none available.

    #182182

    Hey!

    Please login on ThemeForest with the account you have purchased Enfold with and go to Downloads section to manually download the latest version. Currenty Enfold v2.4.1 is available on ThemeForest
    For a quick guide on updating your theme take a look at this video on updating the Enfold theme via FTP: https://vimeo.com/channels/aviathemes/67209750

    Cheers!
    Yigit

    #182196

    Updated the Theme: still the same issue.

    #182307

    Hey!

    That is the way the single product is formatted. The sidebar on single product pages will always be on the left. You can choose not to show it, add this on your custom.css or Quick CSS:

    #top #main .single-product-main-image .sidebar, #top #main .single-product-main-image .inner_sidebar {
    display: none;
    }

    Cheers!
    Ismael

    #220772

    Hey Ismael, how would I go about hiding the sidebar on single product pages for smartphones? The problem I have is that I’m using two widgets on single product pages, but these appear above all the other product details when viewing on a smartphone.

    Even better would be forcing the sidebar under all the other content on mobile devices.

    Thanks in advance,
    Mark

    #220777

    Hey Mark!

    Try setting this option on Enfold > Sidebar:

    Regards,
    Josue

    #221430

    Hey Josue, thanks for the contribution, however, I only want to do this for single product pages.

    On normal, static pages, the sidebar is on the right hand side and when viewed on mobile devices, it moves underneath the main content.

    On single product pages, the sidebar is on the left hand side, directly under the product image. When viewed on mobile devices, the sidebar shows under the image, but above the product description etc.

    I would like to switch the sidebar OFF for single product pages only.

    Any assistance greatly appreciated :)

    Thanks,
    Mark

    #221437

    Hey!

    Try adding this code to the Quick CSS:

    @media only screen and (max-width: 767px) {
    #top #main .single-product-main-image .sidebar, #top #main .single-product-main-image .inner_sidebar {
    display: none;
    }
    }

    Cheers!
    Josue

    #221443

    Thanks Josue, that worked :)

    #221444

    You are welcome, glad we could help :)

    Regards,
    Josue

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Sidebar on Single Product’ is closed to new replies.