Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2773

    Hello,

    I am having problems with simple press in the newscast theme. For some reason, where there are links like the Login, Members and Profile ones in the Login strip the HTML is being outputted with br tags between them so they end up on a line each.

    I looked on the simple press forum and see many postings with answers like below –

    the forum is NOT doing this… something on your site is doing it (theme or another plugin)… we output n characters at the end of some lines to keep the html from all being on one line… and overly greedy themes or plugins may convert (incorrectly) those to
    tags…

    one common thing done is for themes to remove standard wp filters for wpautop and wptextureize and then cause that to happen… check your theme functions.php file and see if its messing with the standard wp filters… or you could switch to the default wp theme briefing and see if it clears up.

    I did switch to the twentyten theme and the alignment problem cleared up. I want to use newscast though but don’t know what to change even with the recommendation from simple press above. Can you help/advise?

    Thanks,

    Matt

    #39237

    Hey,

    try to add following code to style.css:

    #sforum .sficon img, #sforum img{
    display:inline;
    float:none;
    }

    I used this code to make simple press forum “avisio compatible”. I don’t know if it works with Newscast.

    #39238

    Thank you for the suggestion but unfortunately it does not look like it helped, unless I did not implement it correctly. You can see what is happening at http://sonicboomracing.com/forum.

    #39239

    Ok, it seems like simple press outputs the display:block attribute directly so we need to set an important tag. Try following code:

    #sforum .sficon img, #sforum img{
    display:inline !important;
    float:none !important;
    }

    #39240

    Dude – you da man! That one did it. Thank you very much!

    #39241

    Glad that I could help you.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Simple Press forum alignment and Newscast theme’ is closed to new replies.