Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24137

    Hello,

    I have a tagline setup in the backend of WordPress, but when I visit my site homepage it only shows the site name in the title. If I navigate to other pages then it works fine. I have a couple different wordpress sites running Kriesi themes and they both experience the same issue. Any thoughts? I’m running WordPress 3.5.1

    #122485

    Hi,

    Go to Incarnation > Theme Options > Frontpage Settings, select your homepage.

    Regards,

    Ismael

    #122486

    I have the frontpage settings set to my homepage on both themes but that didn’t change anything. On the Incarnation theme, I was able to get the tagline to show up if I set my WordPress Reading settings to: Front page displays – Your latest posts

    Is it supposed to work like that? When I had the front page display as the specific page, then the tagline wouldn’t show up.

    On the Coherence theme I am having the same issue but changing my Reading settings results in the site saying:

    Nothing Found

    Sorry, no posts matched your criteria

    Any ideas on how to get this to work? Thank you for your help thus far.

    #122487

    Hi rksystems,

    WordPress has some issues with the homepage title specifically and themes tend to compound it.

    The best thing to do is use something like Yoast SEO and let it control your homepage title text (as well as general SEO).

    Regards,

    Devin

    #122488

    That’s a great idea Devin. Thank you for the suggestion.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Site tagline not showing up on title’ is closed to new replies.