Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #4728


    I have my site title in “General Settings” set as “Love Is In The Stars”, but on the home page it just shows “soulmatestars.com” (the url of the website!

    When I change the theme to Twenty Ten, it shows it properly.

    Thanks a lot


    PS: it’s fine on the other pages, only see this behaviour on the home page!



    the title is generated in header.php with following code:

    <title><?php if (is_home()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?></title>

    Maybe your blog name is set to “soulmatestars.com” or a seo plugin messes with the title.


    My site title in “General Settings” is set as “Love Is In The Stars”, Is there any where else that needs to be set?

    I changed the header.php code to :

    <title><?php wp_title(”); ?></title>

    but it still just shows soulmatestars.com

    I don’t have any seo plugins yet.

    Only home page shows this.

    When I go to edit page for the home page, it shows for the permalink:

    Permalink: http://soulmatestars.com/

    I don’t have the option to edit the page url.. (which kindof makes sense, since it’s the home page)

    What could be going wrong?




    Do you use any SEO plugins? If yes try to deactivate them to check if they cause the wired title…


    As I said above, I don’t have any SEO plugins!!!


    What happens if you use following code:

    <title><?php bloginfo('name'); ?></title>


    Hey Dude, That seemed to Worked!

    Thaks a lot :)



    Glad that it works now :)


    Hey Dude,

    I didn’t really pay attention before, but as expected, the

    <title><?php bloginfo(‘name’); ?></title>

    displays the same blog title on all pages!

    while if I put in

    <title><?php if (is_home()) { bloginfo(‘name’); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(”); ?></title>


    <title><?php wp_title(”); ?></title>

    they both show the names of pages everywhere except on home page where it just shows the URL of the site but not the blog title.

    Again, my sitetitle in General settings is not the same as the site URL soulmatestars.com but it is “Love is in the Satrs”

    Please help!


    Maybe try:

    <title><?php if (is_home() || is_front_page()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?></title>


    Thanks Dude!

    That actually worked :)


    Glad that it works now :)

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘site title’ is closed to new replies.