Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #5582

    greetings — i’m working with a fresh WP 3.2.1 install (network), a fresh database, and fresh Twicet install. My slider posts, with images and text, are working as expected, but thumbnails appear as broken images.

    The website is for an internet-novice, so i would like to determine why they are not being generated automatically, as opposed to going ‘manual’ and sizing/placing individual images for thumbnails as a solution.

    Twicet reports that my server has the necessary graphics packages installed, automatic re-sizing is enabled, and permissions are opened up on my /uploads and /cache folders. I’d appreciate any help in troubleshooting this, be it Twicet or my server packages.

    Thanks for your help —

    #50956

    here is the link to the site being built http://i-fiction.net/~bnj/

    #50957

    Hey,

    the thumbnails – i.e.: http://i-fiction.net/~bnj/wp-content/themes/twicet/timthumb.php?src=http://i-fiction.net/~bnj/wp-content/uploads/2011/08/500×350.jpg&w=44&h=30&zc=1

    give me a 404 not found error which indicates a problem with the timthumb image generation. Kriesi released an update yesterday which incorporates the latest timthumb version (v2+). It’s highly recommended to update asap because the old timthumb script can be used to attack/hack your server. Maybe the updates solves your problem too. Please download the update at themeforest.net and replace the old files with the updated files (mentioned in version.rtf).

    #50958

    Dude,

    i’m afraid updating the timthumb.php file did not fix my problem.

    I removed the uploaded test images, removed the test posts, updated timthumb.php (and style.css), created new posts and uploaded new images. The problem persists.

    Is it possible to change my password in this forum? i can’t seem to find an option…

    #50959

    some things i have noted for troubleshooting:

    i expected that, being in a network set up, the media and posts would be under …/wp-content/blogs.dir/ … this is not the case, so far the first site is putting content in to /uploads … this may be the proper operation, but the network feature is new to me. The site is installed in a root location, as WP requests, however it does not have a domain name.

    could the fact that this is a network set up, compounded with the site being in a ‘sandbox’ without a domain name, be making timthumb skip a beat? The application goes beyond my PHP knowledge to troubleshoot.

    Thanks for your help.

    #50960

    Hey,

    when you upload media the media is supposed to go to the uploads folder, running your site locally could form some problems with a wrong setup but it should work as on a normal host.

    If the thumbnails don’t work as they’re supposed to I’d suggest you download the latest version of the theme from Themeforest and try a clean installation (of the thee), this way we ensure it’s not the theme but rather edits/plugins malfunctioning.

    #50961

    Chris,

    I’ve already perform a virgin install of the latest Twicet to verify the problem.

    Regards -

    #50962

    I’ll contact Kriesi to check this problem.

    As for your forum password you should be able to change it here if you haven’t already.

    #50963

    Hey! I can only make an educated guess on this one but it might be possible that timthumb has problems with the ~ character in your url.

    Another problem with timthumb ist that is has problems running on wordpress multisite installations. do you use a multisite installation or a default wordpress installation?

    Cheers

    Kriesi

    #50964

    Kriesi,

    it is a multisite installation. I suppose the only thing we can do is see how Timthumb performs when it has a real URL. I’ll let you know what happens when we launch in a couple weeks; if i have to create icons to use in place of auto-generated slide thumbnails, so be it. Thanks for looking in to this.

    #50965

    timthumb has a known problem with multisite installations. you might want to google for “timthumb with multisite” and check out one of the tutorials ;)

    cheers

    Kriesi

    #50966

    Not sure if my issue is related or not – I have just moved my wordpress to a new server and updated the DNS. All is working as expected except the thumbnails… they show as broken images – or rather, as red ‘X’s.

    It worked great before the move – could this be solved with updating the timthumb.php file? If so, where would I find the update?

    See the issue here: http://www.talkspark.co.uk

    #50967

    PS – am running v2.8 of timthumb script.

    #50968

    Hi,

    I believe this plugin can help you.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Slider thumbnails are broken links’ is closed to new replies.