Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8282

    Having speed issues for the slideshow on both my homepage & my portfolio page. The site loads fast – within a second or two – but on an initial visit, the slideshow takes between 12 and 15 seconds to load in Chrome. Once it’s in my browser’s cache, the entire page, slideshow & all, loads within that 1-2 seconds. (Tested this by clearing the browser’s cache & opening my site.)

    I’ve already contacted HostGator & support tried to help me out, but even the test he ran on InternetSupervision.com showed my page loading within 1-2 seconds all over the world.

    I just repeated my testing – cached vs not – on IE. It loaded up quickly for both, but the slideshow didn’t work. This is the error message:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E)

    Timestamp: Tue, 17 Jan 2012 18:46:12 UTC

    Message: ‘methods.switchSlides’ is null or not an object

    Line: 8

    Char: 7583

    Code: 0

    URI: http://karencooley.com/wp-content/themes/flashlight/js/avia_fullscreen_slider.js?ver=1.0.0

    Any ideas on how to improve the speed? Size my images to a certain amount? Thanks in advance for any help!

    Karen

    #60916

    Any ideas?

    #60917

    Hey,

    your website loads very quick for me (in around 2,5 seconds). I’d make sure that the overal page size doesn’t exceed around 800kb otherwise your users will experience longer loading times. I couldn’t reproduce the js error. Maybe try to clear the browser cache?

    #60918

    I changed the slideshow since I last posted and only have one image. Since I did that, the whole thing loads quick. It’s when I add multiple images to the slideshow that it comes to a screeching halt on an initial visit. Only the menu loads quick with multiple images in the slideshow.

    If the overall page shouldn’t be more than 800kb, I assume that would include all of the images used in the slideshow? I’m trying to figure out if I need to resize the slideshow images to speed up the initial load. What size are they on the live preview here: http://www.kriesi.at/themedemo/?theme=flashlight

    Thanks, Dude. :)

    #60919

    Kriesi uses images between 200kb and 400kb – they’re loading in the background while the user views the page.

    #60920

    Thanks, Dude. I’ll make sure my images are that size. The first time I loaded the live preview for Flashlight, it was super fast for me – not the amount of time it takes my page’s initial load.

    Appreciate the help! :)

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Slow loading slideshow’ is closed to new replies.