Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #233130

    Hi all,

    On http://robinhq.com/team/ we have the latest Enfold theme (2.5.4) installed. In Chrome and Safari the social icons (Twitter, Linkedin) are shown, in Firefox they are not.

    We already added the following .htaccess fix, this did not solve the problem:

    <FilesMatch "\.(eot|otf|woff|ttf)$">
    <IfModule mod_headers.c>
            Header set Access-Control-Allow-Origin "*"
    </IfModule>
    </FilesMatch>

    Any idea how we can fix the social icons in Firefox?

    Thanks,

    Robin

    #233184

    Hey robinwo!

    Thank you for using the theme. I hope you’re doing great.

    Have you tried flushing the W3 Total Cache plugin settings? You can also deactivate it first then check the website again.

    Cheers!
    Ismael

    #233200

    Flushed the cache, also my browser cache, this did not solve the problem. Still the same issue with Enfold/Fontello in Firefox (while it does work in Safari & Chrome).

    #233290

    Hi!

    Please check Settings > General, WordPress Address and Site Address should be exactly the same. Add this on .htaccess:

    <IfModule mod_mime.c>
      # Audio
        AddType audio/mp4                                   m4a f4a f4b
        AddType audio/ogg                                   oga ogg opus
    
      # Video
        AddType video/mp4                                   f4v f4p m4v mp4
        AddType video/ogg                                   ogv
        AddType video/webm                                  webm
        AddType video/x-flv                                 flv
    
      # Web fonts
        AddType application/font-woff                       woff
        AddType application/vnd.ms-fontobject               eot
    
        # Browsers usually ignore the font MIME types and simply sniff the bytes
        # to figure out the font type.
        # http://mimesniff.spec.whatwg.org/#matching-a-font-type-pattern
    
        # Chrome however, shows a warning if any other MIME types are used for
        # the following fonts.
    
        AddType application/x-font-ttf                      ttc ttf
        AddType font/opentype                               otf
    
        # Make SVGZ fonts work on the iPad.
        # https://twitter.com/FontSquirrel/status/14855840545
        AddType     image/svg+xml                           svgz
        AddEncoding gzip                                    svgz
    </IfModule>

    Best regards,
    Ismael

    #233336

    Done, did not solve the problem. Also, adding this htaccess code, removing all W3TC htaccess code & emptying caches did not fix this.

    Fonts are included correctly:
    <style type=’text/css’>
    @font-face {
    font-family: ‘entypo-fontello’; font-weight: normal; font-style: normal;
    src: url(‘http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot’);
    src: url(‘http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot?#iefix’) format(‘embedded-opentype’),
    url(‘http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.woff’) format(‘woff’),
    url(‘http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.ttf’) format(‘truetype’),
    url(‘http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.svg#fontello’) format(‘svg’);
    }
    .avia-font-entypo-fontello{ font-family: ‘entypo-fontello’; }
    </style>

    Note: this code is shown twice in our <head /> section. We needed to add this code manually, as the font did not load correctly on subsites on our multisite: urls to the font files were generated based on subsite url (not correct url to font file), instead of network site url (correct url to font file).

    • This reply was modified 8 months, 3 weeks ago by  robinwo.
    #234153

    Hey!

    Please try to change the theme folder name. I noticed the url path is a bit weird

    
    
    http://robinhq.com/wp-content/themes/enfold-2.5.4/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot
    
    

    and maybe the folder name enfold-2.5.4 breaks it. Try to rename the theme folder to enfold.

    Regards,
    Peter

    #234170

    That’s done for a reason, safely updating theme (and child theme) versions.

    An (older) version of the theme is available in the /enfold/ folder, all font files can still be downloaded from this folder (for example http://robinhq.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot). So the font files are available, independent from this theme dir (and as stated before, it does work in Chrome and Safari).

    Note that there’s also a bug in this theme on WordPress multisites: urls to font files are based on $this->paths['baseurl']. In a multisite, this baseurl is the site’s url, while this should be the network site’s url (https://codex.wordpress.org/Function_Reference/network_site_url).

    • This reply was modified 8 months, 3 weeks ago by  robinwo.
    #234174

    Hey!

    I’ll tag this thread for Kriesi.

    Note that there’s also a bug in this theme on WordPress multisites: urls to font files are based on $this->paths['baseurl']. In a multisite, this baseurl is the site’s url, while this should be the network site’s url.

    I can’t find a bug. I did a quick test on my multisite test server and the urls are correct for me: http://multisitetest.inoplugs.com/ and http://en.multisitetest.inoplugs.com/ on my test websites.

    http://en.multisitetest.inoplugs.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot

    http://multisitetest.inoplugs.com/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/assets/fonts/entypo-fontello.eot

    and custom icon font urls:

    http://en.multisitetest.inoplugs.com/wp-content/uploads/sites/2/avia_fonts/fontello/fontello.eot

    http://multisitetest.inoplugs.com/wp-content/uploads/avia_fonts/fontello/fontello.eot

    Imo the different url paths are correct or you may run into issues because of the cross domain references.

    Best regards,
    Peter

    #234380

    Hey!

    Font file issue might be caused by a corrupt file set. please see my answer here: http://www.kriesi.at/support/topic/after-update-in-firefox-26-font-face-broken/

    Replacing the font files again seems to have solved the problem
    Regards,
    Kriesi

    #234588

    Strange, it does not work on our multisite (perhaps we use /…/ for our sites, instead of subdomains?).

    Also replacing the font-set fix did not work for us, still no icons on Firefox (also not after empyting all W3 caching).

    Note: Just did a clean upload of Enfold 2.5.4, still the same issue on Firefox!

    • This reply was modified 8 months, 3 weeks ago by  robinwo.
    • This reply was modified 8 months, 3 weeks ago by  robinwo.
    #235210

    I’ve got the same issues, shreinmedia.co.

    https://www.dropbox.com/s/n6dcxkyc4tm8z0h/Screen%20Shot%202014-03-10%20at%208.59.29%20PM.png

    Running all the latest everything.

    #235338

    Hey!

    Would you mind updating to version 2.6? It uses the font set I used to fix the problem mentioned in the other thread. If that does not work either please drop me your ftp credentials in a private reply and I will take a look at the files…

    Best regards,
    Kriesi

    #235965
    This reply has been marked as private.
    #235970

    Hi!
    @shreindesign:

    In your case the server was causing the problem and the codesnippet in the first post by @robinwo solved the issue. Just in case that you ever run into that problem again please try to add this snippet to your .htaccess file :)

    Best regards,
    Kriesi

    • This reply was modified 8 months, 2 weeks ago by  Kriesi.
Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Social Icons (Fontello) not working in Firefox, Enfold 2.5.4’ is closed to new replies.