Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #23571

    Hi,

    I just finish to installed your template. i bought it because there are events, WPML, … and it seems that i have many problems .

    I import your dummy data, and on all pages i have 404 error. If i activate Permalink, i have all 404 errrors.

    My default language is french and a second language english.

    What can i do to solve this problem

    thanks

    #120347

    Sorry,

    So i try to desactivate all , put permalink… and after i activate WPML

    By default, i put english and the second language is French.

    Actually i just translate one page to test it. About us… when i run the first time it’s working,. and when i try french , the page is displayed and when i m back to english… the page is 404 … impossible to have the original page in english !!!

    It’s really Urgent.. someone can help me ? thanks

    http://95.215.225.21/~interrel

    #120348

    Hi,

    When using WPML you need to sync the website for each language. If you create About us for English language then you need to create another one for French. This is an elaborate instruction by Nick for WPML.

    http://www.kriesi.at/support/topic/callout-translation-wpml

    WPML is not the type of plugin that you activate and it takes care of everything else. You need to first set it up and configure it. Also you are aware that there are multiple versions of the plugin (cms & blog) with completely different functionality? Which version are you currently using? Is your site being setup as a blog or a cms?

    Please refer to the http://wpml.org/documentation/getting-started-guide/

    1) After you activate the plugin, you click the configure link right under its name in the Plugin section of the backend. You select the current language, the languages which you wish to translate into, then you select the language switcher options that suits your website, and click Finish.

    2) Now on top of the backend you see the language dropdown box showing the root language of the site – English lets say, and I selected Spanish as the translation( for this example). You now have two completely different backends in your site which are *independent of one another*, an English and a Spanish. So you first create a home page, or a portfolio page,or any page in English backend and save it. Then you use the language dropdown box on top in the backend to switch to the Spanish version of the backend , and *re-create* or import etc.. the Spanish versions of your English pages. You will notice in the backend the menu link ‘Flagship’ will become ‘Flagship EN’ and will change to ‘Flagship ES’ when you use the dropdown to enter the various versions.

    So, to answer your question. , If you have an English (root) template which you applied to a page you designated as your homepage. you would switch to Spanish (or your language choice) . But you would *NOT* see those templates nor the pages you just made because those are in the ‘English backend’. You would have to recreate them all over in the Spanish version. Then create a new Spanish page, apply the Spanish homepage template to it, and link it to the English home page via the dropdown in the Add Page or Add Post pages.

    If you’ve done all the above, and linked the translated version to the root version of the page and still are not seeing anything, please try re-installing the plugin and do speak to the WPML support staff and I am certain between the two support teams we will get you running smoothly.

    Cheers,

    Ismael

    #120349

    To fix this issue, add the following line to your functions.php

    flush_rewrite_rules( false );

    right above

    /*

    * register custom functions that are not related to the framework but necessary for the theme to run

    */

    require_once( 'functions-enfold.php');

    Please note: this way it should be used only for development purposes. If you encounter any load time issues, wrap the call within a function upon activation of the theme. Be aware, activating any other third party plugin MAY overwrite the rule. Also, if you add a new category, rewrite rules will be forced to flush. If you use the activation hook, simply disable and re-enable the Enfold theme.

    #120350

    After some more investigation in this issues with 404 (and probably plugin errors, MCE non-functional) I suggest you to check your PHP memory_limit. Common settings for this value is only about 64M (even with professional hosting), which will be very fast consumed by the avia framework, layerslider and other components. If you use some more plugins which allocate unusual high memory, you will run out of (PHP) memory.

    To get Permalinks working, flush_rewrite_rules should be “true” (remove any lines you may have inserted) and after raising the memory allocated to PHP save your Permalink structure once. Everything should be okay.

    If you just like to check it, set WP_DEBUG to “true”, switch to your backend, edit a post or page an have a look at the very end of the page. If there’s an error present stating that memory allocation is exhausted, you have to increase the memory_limit.

    Thanks to Chris who finally found the error message… :)

    #120351

    Hey,

    Thanks formateins.

    Cheers,

    Ismael

    #120352

    Thanks a million for your solution, formateins. It saved us a lot of time!

    @Ismael, it seems that there are still issues with the permalink structure.

    Apparently Enfold cannot resolve the %category% structure tag.

    All possible variations of permalinks work and lead me to my posts, but whenever I choose /%category%/%postname%/ as my custom permalink structure I get the 404 errors again.

    Can you please look into it?

    Thanks.

    #120353

    Ismael,

    The problem with the categories in Enfold may even be bigger than just the permalinks issue.

    When I list all my posts in my dashboard and filter on category, I get a “No results found” back, even though the posts are there (I can search for them through the regular “Search Posts” form. When I hit filter again I get an “Invalid post type” error…

    And when I want to go to my category overview (the overview of posts of a particular category), I get a 404 Nothing Found error, not matter my permalink structure.

    Can you please have a second look at how Enfold treats categories?

    I hope you will be able to communicate a solution soon. The theme is absolutely gorgeous and user-friendly except for this issue.

    Thanks.

    #120354

    Hi lincelot,

    I’ve tagged Kriesi on the topic as he’ll be the best one set to dig deeper on the issue based on the description.

    Regards,

    Devin

    #120355

    I’ve had a similar issue – I’m using WPML – and I’ve set up both English (default) and German, and they both have worked (with the default permalink setting), but the events calendar won’t display the navbar in this setting, so I’ve gone back to the /%postname%/ setting, and it works a little, but the “sermons” page breaks in english… and whenever I make almost any changes, the whole site starts sending “404’s”

    my client loves the template – but I need it working – please help :)

    emmausway.org

    #120356

    I just added the:

    flush_rewrite_rules( false );

    in the functions.php file and everything seems to be working again…

    can you explain the repurcussions of making “flush_rewrite_rules” false?

    Will I need to manually override this later?

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Some problems 404 ,permalink and WPML’ is closed to new replies.