Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #21530

    Hi,

    Guys I need your help. I have WP 3.5.1 and Magic Members plugin running on my site. I set up the system and I was ready to launch. I ordered SSL to protect the PayPal Pro credit card payments but now as soon as you reach the PayPal form there is a running circle (busy) and a message “Processing payment, do not refresh page….”. I tried everything with the plugin and the support they claim something is wrong with the theme, I contacted Media Temple, they helped as much as they could. So now I am here :).

    I have seen that some people had similar issues with the SSL checkout and Angular theme. I enabled PHP error logging and in the moment of that problem I get a lot of error messages like this:

    PHP Strict Standards: Declaration of avia_backend_walker::start_el() should be compatible with that of Walker_Nav_Menu::start_el() in /nfs/c10/h02/mnt/141962/domains/bootcampcoffee.com/html/wp-content/themes/angular/framework/php/class-megamenu.php on line 331

    I checked the line 331 but there is no http that i could rename to https. I guess there is plenty of cross referring. Can you be so kind and translate this error? Can you help me to identify the problem?

    Thank you very much.

    #112158

    Oh and I forgot that the Web developer firefox plugin gives me this error. Maybe it is also a hint:

    Timestamp: 3/23/2013 10:00:21 AM

    Error: google-translate: An exception occurred.

    Traceback (most recent call last):

    File “javascript:on(“click”, function (node) { var url = node.href;postMessage({ url: url });});”, line 1, in

    File “resource://jid0-k75tfrgfoxphfezmj9cku5ecglc-at-jetpack/addon-sdk/lib/sdk/content/content-worker.js”, line 256, in deprecatedOn

    console.error(“DEPRECATED: The global on() function in content ” +

    ReferenceError: console is not defined

    #112159

    Just search for “PHP Strict Standards: Declaration of” (eg with google) and you’ll get a lots of results:

    https://bugs.php.net/bug.php?id=46851

    http://stackoverflow.com/questions/11962564/php-strict-standards-declaration-of-should-be-compatible-with-that-of

    I’d try to turn off the E_STRICT mode.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘SSL Checkout’ is closed to new replies.