Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #11568

    Hi! SSL doesn’t work proper;y to the pages which should be adapted, but these pages appear with URL: https://,,,,,,,,,, on browser. I checked some settings before asking which are DNS records, Matching WordPress’s URL and site’s URL and IP adress settings. In an administrator of rental server’s opinion: “You have to change a type of ulr paths from absolute to relative” Is it necessary to modify? I’d like to know how to solve the problem.

    http://singhiousou.com

    Thanks in advance.

    Regards,

    Sen

    #72191

    Hi!

    Please try to activate the “force ssl” option on the woocommerce settings page. As far as I know you need to configure the ssl connection with the server configuration.

    Regards,

    Peter

    #72192

    Thanks for your advice, Peter

    Though regrettable, of course, I know the arrangement.

    And in the whole composition, I am confirmed immediately, after purchasing this theme.

    Is change of path unnecessary although asked once again? Is there neither what some should otherwise be checked for, nor solution?

    Regards,

    Sen

    #72193

    Hi Sen,

    You can try changing the WordPress Address to https in the Settings>General Settings as well.

    Regards,

    Devin

    #72194

    Hi! Devin,

    Thank you for reply.

    I tried to change the setting as you adviced, but nothing has changed.

    If I need to rewrite the type of path from absolute to relative for enable to ssl adopted pages,

    Which page and part do I have to rewrite and how to rewrite? or add some scripts?

    Regards,

    Sen

    #72195

    Hi Sen,

    I’m not sure what specific item isn’t getting delivered via https over http so I’m not sure where best to direct you. There isn’t really a single spot where you would change things.

    If you can pull the site out of maintenance mode, we can try and take a look at what the specific items that are not getting loaded in “securely”.

    Regards,

    Devin

    #72196

    Hi! Devin,

    Thank you for your reply.

    I changed to be unable the maintenance mode.

    Although it seems that there is no same question in support forum.

    Is this problem only I have? I hope you find a solution!

    Thanks in advance.

    Regards,

    Sen

    #72197

    Hey Sen,

    I believe the issue is loading in the google fonts. They are being loaded in from the google domain so the site shows as “not secure” because of that content being loaded in.

    You’ll need to open up the class-style-generator.php located in the framework>php folder. Search for:

    http://fonts.googleapis.com/css?family=

    and then change the http to https . This should force the fonts to load securely into the page.

    Regards,

    Devin

    #72198

    Hi! Devin,

    Wow! You solved the issue completely and quickly.

    You are really great. I appreciate your valuable support.

    Thanks for taking the time to solved the problem.

    Regards,

    Sen

    #72199

    Hi Sen,

    Glad Devin was able to help you! Let us know if you have any more questions.

    Regards,

    Mya

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘SSL issue’ is closed to new replies.