Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #192149

    Hi,
    I found the same SSL problem of Enfold like “http://www.kriesi.at/support/topic/request-to-modify-for-ssl-problem/”
    I set up SSL my domain but only using Enfold theme had some problem as follow;
    1. favicon URL never change from http to https.
    2. I checked my site by http://www.whynopadlock.com/ and found one insecure items as follow;
    Insecure URL: http://www.auvent.de/wp-content/uploads/2013/11/logo-auvent-neu.png
    Found in: https://www.auvent.de/mein-konto/
    The secure URL is only for the shop “…/shop/” and not for the complete domain.
    I don’t use the WordPress Plugin: WordPress HTTPS (SSL). I have problems with this plugin in combination with nginx, ngx_pagespeed and varnish.
    Can you fix this in your theme?

    Thank you,
    Regards

    #192839

    Hey Torsten!

    The favicon and logo url depends on your input and it’s not a theme issue. If you want to replace http with https go to Enfold > Theme settings and make sure that the image urls use the https:// protocol instead of http://. If you need to change it click into the text field of the logo/favicon url option and add the “s” to http://.

    Cheers!
    Peter

    #193228

    Hi Peter,

    vielen Dank! Das funktioniert zwar, aber ist leider nicht was ich wollte. Die Dateien die über HTTPS übertragen werden, können durch Varnish nicht gecached werden. Auch eine Änderung des Logos ins Base64 Format durch ngx_pagespeed funktioniert so leider nicht. Damit wäre mein Problem gelöst. Gibt es keine Funktion, die feststellt, ob Daten per HTPS übertragen werden und die URLs des Logos, des Favicon und evtl. weiterer Dateien entsprechend geändert werden? Ich will nicht die gesamte Webseite über HTTPS übertragen.

    — Here my poor english (Googles best friend):
    thank you! This works, but is not what I wanted. The files are transferred via HTTPS can not be cached by Varnish. A change of the logo into Base64 format by ngx_pagespeed works so unfortunately not. So my problem would be solved. Is there any function that determines whether data is transmitted by HTPS and the URLs of the logo, the favicon and possibly other files are changed accordingly? I do not want to transfer the entire website over HTTPS.

    Viele Grüße
    Torsten

    #193428

    Hi!

    You can try to replace following code in header.php

    
    	 if (function_exists('avia_favicon'))    { echo avia_favicon(avia_get_option('favicon')); }
    

    with

    
    	 if (function_exists('avia_favicon'))
         {
            $avia_favicon_url = avia_get_option('favicon');
             if(!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off') $avia_favicon_url = str_replace("http://", "https://", $avia_favicon_url);
             echo avia_favicon($avia_favicon_url);
         }
    

    and in /wp-content/themes/enfold/framework/php/function-set-avia-frontend.php replace

    
    $logo = "<img src='{$logo}' alt='{$alt}' />";
    

    with

    
    if(!empty($_SERVER['HTTPS']) && $_SERVER['HTTPS'] !== 'off') $logo = str_replace("http://", "https://", $logo);
     $logo = "<img src='{$logo}' alt='{$alt}' />";
    

    Make sure that the image urls (theme option panel) use http:// as the default protocol.

    Regards,
    Peter

    #193601

    Hi Peter,

    thank you very much! It works perfect and its great. Works with nginx, varnish and ngx_pagespeed.

    Regards,
    Torsten

    #193754

    Hi!

    Great :)

    Cheers!
    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘SSL Problem’ is closed to new replies.