Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #14545

    I have Sentence and am happy with it so far. Its for an informational site and it looks great for this. I am having a problem with the slider though. I have the blog on a page named Blog, and a page that I have named Medieval Times (the name of the site.) I have this Medieval Times page set as the front page / home page.

    When I add a post and put an image in that post it shows up in the post fine, and at the top of the blog page fine. The problem is that those images are also showing up on the static home page. I do not want them there. I would like the option to put other images there when I choose to, but I don’t want my blog posts showing up in the slider on the home page.

    #83900

    Hi greggh,

    As far as I know the theme does not have the ability to load in a specific slideshow when you set the frontpage to be a static page.

    Can you provide a link to your page that is incorrectly showing the images from the blog so we can inspect the code a bit and see what might be happening?

    Also check that in your main theme options under Portfolio, that each of the portfolio blocks (starting with the categories selector and ending with the portfolio width) is assigned to a specific page. If any of them are not, either assign them to one from the dropdown labeled “Which page should display the portfolio?” or remove that portfolio set with the Red X at the bottom right.

    Regards,

    Devin

    #83902

    This is just a temporary holding spot until I am done with the site and move it over to the real domain: http://anonbw.com/mt/

    I dont want the blog slider on the front page. I would like it to use the slider from the page that is currently set as the front page, that seems like the way it should work.

    I have not done anything with portfolios, and I dont want any portfolio items at all. When I go to Sentence->Portfolio it has one section titled “Which categories should be used for the portfolio?”. This has a green + and a red x at the bottom. I hit the red x and it does nothing. It doesnt remove that section, even after hitting save.

    #83903

    Hmm, I’m not quite sure how the blog slideshow is getting inserted into the static frontpage. As far as I know there isn’t any way to set a slideshow for the homepage unless it is set as the blog.

    Can you create a temporary admin account so that I can take a look at the back end settings and see if I can diagnose what is causing the issue. I’ve seen portfolio slideshows pop up incorrectly if they aren’t assigned to a page but not the images from a blog post.

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

    #83904

    credentials sent.

    #83905

    Any answer yet? I am not trying to be rude, but I wanted to make this site live 3 days ago.

    #83906

    Hi greggh,

    Let me tag Devin. I’m sure he’s working on it, there are many inquiries lately and he may have missed this topic.

    Regards,

    Ismael

    #83907

    Thanks Ismael, I appreciate any help!

    #83908

    Hi greggh,

    I’m taking a look at this now. Not sure how I missed your email but I did receive it.

    Regards,

    Devin

    #83909

    Anything yet? I hate to be a pest, I am still waiting so I would love an update.

    #83910

    Hey greggh,

    I ended up trying to just recreate the same issue on my own installation but I can’t seem to re-create the same bug. I’ve asked the other support to take a look at it as well.

    In the mean time, have you tried adding a photo/slideshow to the page you have set as the home page and if so did it have any effect one way or another?

    Regards,

    Devin

    #83911

    DEVIN

    Hmm, I’m not quite sure how the blog slideshow is getting inserted into the static frontpage. As far as I know there isn’t any way to set a slideshow for the homepage unless it is set as the blog.

    That’s concerning me…

    I have just purchased this theme and I’m having the same type of problems. It appears that if I create a page, put a slideshow in it and some column content below, it shows beatifully. But If I make that page home page, the slideshow does not show. All I see is the non slideshow content. There must be a way to do this. Basically I don’t want a blog a s a home page, I want a slideshow with some content. below This is the only theme Ive used that appears to make this difficult. Any resolution please??

    #83912

    Hi HouseofStrauss,

    I believe Kriesi has stated in the past he hadn’t written or designed for the front page to be able to display a slideshow as it was designed for the blog layout only. He did just (2 days ago) however say he would look into the same issue not happening so I’ll need to double check to be sure. As of now, I don’t believe Sentence 1.4 does have support for it.

    Regards,

    Devin

    #83913

    Hi Devin, thanks for your reply/

    As of now, I don’t believe Sentence 1.4 does have support for it.

    That’s disappointing and looking around this forum, I see a significant number of customers wanting to do this. As an option, I would have thought this feature would have been obvious. For immediate workaround I have used a redirect so that the home URL goes to a static page, with a slideshow on it. Hacks like that should not be required. I think many people would appreciate a fix for it. I call it a ‘fix’ because this is the only theme I know of that can’t show a slideshow on the home page. Maybe it should have been clearly stated that the homepage is BLOG ONLY, or static page without slideshow.

    Thank-you

    #83914

    I just want the front page on mine not to show the blog slider. I dont know why its doing it. But I need to get that fixed before I can go live.

    #83915

    Hi greggh,

    The only thing I can think of at this point is that perhaps a plugin is effecting the loop on the front page in a very odd way. Try disabling all plugins currently active then checking out the home page again.

    If that doesn’t work, it try re-downloading the theme from your downloads on themeforest then installing it on top of your currently installed files. You can do this in the same way you first installed the theme (either FTP or through the WordPress admin).

    Finally, if you need to just get rid of it right now, you can add the following css to your Quick CSS in under the Styling tab of the theme options:

    #top.home .slideshow_container.big-slideshow {
    display: none;
    }

    Regards,

    Devin

    #83916

    Using CSS to hide an item after the fact, and having the php go through the work of creating the slider, is not a very good solution.

    Disabling plugins didnt help.

    I am going to dive into the php and see if I can figure it out I guess. I just didnt want to do much in the way of code edits, makes it hard to update to the latest versions.

    #83917

    I agree and it definitely isn’t ideal. I really can’t say for sure why it has this behavior as I’m still not able to duplicate it on my end and the other support crew I’ve asked have had the same non-results.

    I would still suggest trying to de-activate all plugins and then re-installing the theme files again (making sure to get the latest version from your downloads on themeforest).

    Regards,

    Devin

    #83918

    I fixed it myself, but not in a way I think is correct. This is just a way that works “for now”. I would love a more professional fix.

    Here is my current working fix:

    In the file includes/loop-page.php there is a line:

    <?php if($slider->slidecount) echo $slider->display(); ?>

    I have replaced that line with this:

    <?php if($slider->slidecount && !is_front_page()) echo $slider->display(); ?>

    Then in my wordpress admin settings I have gone to Settings->Reading and set the Front Page to my actual front page.

    This makes it stop showing the slider on the front page for now, but again, I would prefer a built in solution that doesnt have me hacking away at his code.

    #83919

    That sounds like a pretty straight forward fix. Again though, I’m still not sure why that behavior was happening with your theme alone. I wasn’t able to re-create the same behavior on a test install.

    I’ve not heard back from or seen a response by Kriesi regarding support for a Front page slideshow but as soon as there is an update it will be posted.

    Regards,

    Devin

    #83920

    I would consider switching to another one of Kriesi’s themes, but I have a very specific need. This is the only good looking theme that actually meets that need. I need a very wide menu of links on the left side. I haven’t found any other themes that have one as wide as Sentence does. Its great for that.

    #83921

    This is what I hope is the final version of the edit. This version now allows you to have a front page slider, and makes sure the blog slider doesnt show up.

    Same file, includes/loop-age.php, replace this line:

    <?php if($slider->slidecount) echo $slider->display(); ?>

    with this code block:

    <?php

    if($slider->slidecount && !is_front_page())

    {

    echo $slider->display();

    } elseif (is_front_page()) {

    $slider = new avia_slideshow(get_option(‘page_on_front’));

    echo $slider->display();

    }

    ?>

    Make sure your front page is set correctly on the Sentance settings and on the wordpress Settings->Reading->Front Page setting. Both are needed for this to work.

    This solves all of my problems it would seem. Maybe this could be included somehow into the next version.

    #83922

    Glad you were able to find a working fix for the issue. I’ll forward the information over to Kriesi and mark the topic for his attention.

    Big thanks for posting your solution as well :)

    Regards,

    Devin

Viewing 23 posts - 1 through 23 (of 23 total)

The topic ‘Static Front Page, Blog on separate page, Slider from Blog showing on Front Page’ is closed to new replies.