Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1601

    How do I set a static page #1 like the live preview on Themeforest with featured image and 4 columns underneath followed by the widgets and footer? I want to add a blog link to main nav, did that. But how do I set a static page like the live preview so the first thing people don’t see if my blog or portfolio?

    Also, how do I change the title of whatever page is open on the browser window? I’ve been messing around with setting my static page to my portfolio and it just displays my full website as the title “www.mywebsiteexample.com”.

    One more thing, sorry, is it possible to change the font of the main nav using cufon? If so, let me know! Thank you thank you!!

    Thanks for your help! Amazing theme, I’m having a lot of fun with it! Can’t wait to finish my site!

    #35817

    Ok i figured out how to do the static page by using the shortcodes. But the page still doesn’t display the title, only displays the website URL like “www.mywebsiteexample” as the title of the page. Any way to fix that? Also, please let me know about changing the main menu navigation font changing question, thanks!!!

    #35818

    Hey,

    The easiest way to get started having read through the documentation is to use the content importer on the main options page, ideally on a fresh installation.

    What’s the URL of the page you’re having issues with?

    James

    #35819

    Hey thanks for the reply, my issue is just having the title bar of the browser window not display the title of my page. It just shows me web address. I want it to say the name of the site and then when you click on a link on the main nav, i want it to say my name and then whatever page you’re at. I’m not done working on it or uploading all my work but check out http://bit.ly/aCaAfh and you look at the title of the page on the browser window when it loads.

    I think what caused it was making the a static page the front page instead of the blog. Thanks for your help! Also, if its possible to, am I able to check the main nav font using cufon also, just like all the headers, if not, no biggie, thanks again!

    #35820

    Hey,

    The page title is set in header.php in this section:

    <!-- title -->
    <title><?php if (is_home()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?></title>

    Have you modified this at all?

    The bloginfo(‘name’); code is the Site Title set in the General Settings in WP admin and should be “Fernando Silva” – this is also displayed in footer.php (unless you changed this) which indicates it’s correct.

    James

    #35821

    Here’s what I did, and the reason I asked this question. And yes I did edit the footer.php because when I didn’t add a site title (there’s a reason I didn’t, I will explain), nothing showed up on my copyright. When I did add a site title, it would only had my name is the blog so it would be called “Fernando Silva Blog” on the title bar.

    The rest of the pages such as Contact and About, are fine, but don’t have my name/site title before them. AND the front page, the first page you see when you visit my site, still does not have a title when I add a site title.

    Then, if I go and do what you just said to do in the header.php (I tried it before because I’ve seen another post in this forum) The blog will then say “Fernando Silva Blog Fernando Silva”, so it doubles my name on the blog, but the rest of the pages are fine, including my front page. So I can’t win any which way, all because I don’t have a blog as my front page. Maybe there’s a way around this you might know?

    I left my site with the site title I just added so you can see what I mean and with the my name in the “blog name” in header.php.

    #35822

    Hey,

    I see what happened – the site name is being called by the bloginfo(‘name’); and also by wp_title(”);.

    Try changing the title code from this:

    <!-- title -->
    <title><?php if (is_home()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?></title>

    to this:

    <!-- title -->
    <title><?php wp_title(''); ?></title>

    and add the site title to General Options.

    James

    #35823

    That didn’t work also. Nothing showed up, only the titles for page’s showed up for example if you would click on “Portfolio” it would only display portfolio on the title bar but no name after it or on the front page.

    Here’s what I did though messing around with it:

    I completely took out the site name under general options.

    Then I went back into header and inserted my name like this:

    <!-- title -->
    <title><?php if (is_home()) { bloginfo('name'); ?><?php } elseif (is_category() || is_page() ||is_single()) { ?> <?php } ?><?php wp_title(''); ?> @Fernando Silva</title>

    that sort of fixed it and now I have a title for every page except my first page says @Fernando Silva and blank in front of it, but i guess i could live with that since there’s no other fix.

    The code you gave me looks like it could have worked, I don’t understand why, damn wordpress. I really appreciate your help James, thank you so much!

    #35824

    Hey,

    If you change the code to only use the WP generated title (as per the code I posted previously), and install the WordPress SEO plugin you can specify exactly what shows up as the title (and description) on a per page basis. I’ve used this on a client site and it’s a fantastic plugin.

    James

    #35825

    Awesome! Thank you so much! :)

    #35826

    Thank you for this thread… I was having a similar problem and the code above fixed it for me.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Static Page Question’ is closed to new replies.