Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #13813

    Try this:

    Type in http://www.indonesiadetective.com/

    Everytime I visit this page for the first time I see the right sidebar with “pages” categories and archives.

    Then click on the about page and after that has loaded click back on the homepage.

    NOW the homepage looks like the way I created it.

    The sidebars I created (with a image widget) do not show up first time.

    How can this be solved?

    Thanks

    Paul

    #80726

    i think this is youre HOME page, which u must set in WP backend.

    go to settings and then readings > there u can set HOME for homepage.

    this should work i think cause the klick on your logo shows the wrong content but the click on HOME the correct content!?

    isnt it ?

    #80727

    you can try the same procedure as u describe above with one change:

    click on logo instead on HOME button and u receive every time the not wanted content.

    #80728

    Hi!

    1) Make sure that you didn’t select a static front page (Settings > Reading).

    2) Select your front page via the theme options panel (Choices > Theme Options > General).

    I think this will solve your issue.

    Regards,

    Peter

    #80729

    Thanks for your suggestions. Unless I am doing something wrong the problem remains. In general settings the reading is not static and home is home. In theme options the front page is home. What am I missing?

    #80730

    Any ideas on this? The issue still remains even though I have followed the advice given.

    #80731

    Hi cpwilson2,

    I think your menu might just be pointing to the wrong “home”. In your menus manager, see what the link is for the home button and change it to just your site URL. As is, it points to /home where you want your site to load the index.

    Regards,

    Devin

    #80732

    I am afraid non of the suggestions have worked so far. I noticed that the permalink on the home page is ……./home and can’t be changed.

    HOWEVER, I tried changing the settings reading page to a static page. This is opposite of the advice you gave but seems to work. Given it is opposite of what you advise am I letting myself into some future troubles?

    Best wishes

    Paul

    #80733

    Hey!

    No, it’s correct now. However I’m curious why the frontpage permalink doesn’t change. Never came across this issue before…

    Regards,

    Peter

    #80734

    I have no idea Dudu. But it works. So long as it does not have any problems waiting to happen that is fine.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Strange homepage behaviour’ is closed to new replies.