Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #263413

    Hi,

    I have just updated your Replete theme to the latest version and now I am facing this weird issue.

    Basically, it seems like the navigation tree in the back-end cannot be longer than 76 items? On the another copy of website, I still have the old version of your theme where the menu works fine.

    What is the error?
    Any menu items after the aforementioned number gets removed entirely on menu save action, and the very last item gets “custom” type of menu item.

    Additionally, the menu loses its assignment to navigation holders.

    Screenshot: https://www.dropbox.com/s/c8j4vdv7ptcdki0/Screenshot%202014-05-12%2017.17.31.png

    I am on WordPress 3.9.1

    #263691

    Hi NerdCow!

    It sounds like that with the updated theme version or WordPress version you are running out of available memory on that installation. You can try increasing it and see if that helps: http://www.dailyblogging.org/wordpress/increase-wordpress-memory-limit/

    Best regards,
    Devin

    #263831

    Hi Devin,

    Thanks for popping in.

    Unfortunately this is not the problem. I have the memory limit set to 768M, which waaaay far more than the development server, where everything works fine.

    Would you rather check it yourself in the admin panel? I would give you access details.

    #264346

    I have encountered this exact same problem several times with Enfold. Any thoughts?

    #264565

    Hi guys,

    Not sure if you are looking into this, but I found out that there must be a problem with your custom nav walker.

    if you comment-out two filters, which are causing errors everything is back to normal … apart from your custom nav does not work :)

    file: class-megamenu.php
    lines: 41 and 44

    Could you please try and fix this as soon as possible and release an update? Meanwhile, I will try to do it myself and let you know how it goes.

    Thanks

    #264572

    Oh and just to answer your future question you may have…

    I have tried:
    1. Disabling all plugins, but did not help.
    2. Switching back to 2014 theme, where longer navigation works w/o problems.
    3. I have absolutely no custom coding on my side to your theme. It must be your back-end nav walker causing problem.

    Thanks

    #265328

    Can I get your input on that, please?

    #265627

    I’d also like some input here, this bug has been driving me crazy and it’s been an issue for several versions of the theme. I’m going to try commenting out the lines as NerdCow has suggested, but an official response would be appreciated.

    I’ve also tried increasing the PHP memory, which seemed to work on one server but not another. Very confusing.

    *UPDATE* NerdCow, commenting out those two lines in the class-megamenu.php file did fix it on my end as well. I’m going with that fix for now. Thanks for your help! Hopefully this will be addressed officially somehow.

    • This reply was modified 3 months, 2 weeks ago by  designpoint.
    #265749

    Im happy it helped you too. I have attached the class-megamenu.php file from the previous release. Just replace it in your replete/framework/php folder and you will be fine.

    http://pastebin.com/u3z0WHan

    Meanwhile, waiting for Replete team to get back to us :)

    #267053

    Hey!

    I’ve tagged Kriesi on the topic as this is the first issue I’ve encountered like this. If it isn’t the php memory issue then it is a php.ini setting for max input vars. There shouldn’t be anything with the mega menu that would cause a limitation but maybe its in how the addition adds more options that are getting submitted at the same time.

    As an aside, each time someone responds to a topic it pushes it to the end of our visible queue. So each self-responds delayed when we would see the topic.

    Best regards,
    Devin

    #267066

    Hey!

    http://sevenspark.com/wordpress/menu-item-limit

    The article describes in detail what you are experiencing and also tells you what to do to solve the issue :)

    Cheers!
    Kriesi

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.