Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #5804

    In my fresh Newscast installation I get some strange layout effects in sidebar and footer: When there is a link (tag “a”) I get a separate line for that link, the image you associated with the li tag and a bottom line. Example: Sidebar (Lates tweets, ) Centre Footer widget (Termine).

    Some images just don’t appear. Example: Sidebar (Getwitter, my avatar is missing), comment section below article (every comment and every reaction gets the “arrow icon” and the avatar of the person doesn’t appear)

    URL for Examples: http://injelea-blog.de/2011/08/31/mit-dem-bus-zum-ibm-social-business-jamcamp/

    I tried to correct this behavior in style.css, style1.css but failed :-) so I reverted.

    I dislike having a bottom line and a special icon for every li item. How can I disable that for all sidebars, footers and for the content? What entries in style.css, style1.css should I change?

    BTW I disabled all plugins but the behavior remained so I enabled them again.

    WP 3.2.1 with Multisite enabled

    #51802

    Hey,

    in css/style1.css delete following code:

    .sidebar .box li a,  .box .recentcomments, .entry ul li {
    background:transparent url(../images/skin1/bullet1.png) no-repeat scroll 0 12px;
    border-bottom:1px solid #D6D6D6;
    }

    .box li a, #footer .box .recentcomments{
    background:transparent url(../images/skin1/bullet1.png) no-repeat scroll 0 12px;
    border-bottom:1px solid #333;
    }

    #top .entry ul li {
    background:transparent url(../images/skin1/bullet1.png) no-repeat scroll 0 9px;
    }

    #51803

    I removed the code. The image and the bottom border disappeared. But still links get a separate line in footer and sidebar as well as images like the authors’ images of comments (from disqus) disappear.

    I reverted to Twenty Eleven theme and everything looked fine. Screenshot on Flickr: http://www.flickr.com/photos/injelea/6143357897/sizes/o/in/photostream/

    Then I switched back to Newscast. Images are gone again. Links have a separate line again. As I mentioned before disabling the other plugins doesn’t help…

    #51804

    Try removing

    #sidebar .box a, #main #sidebar .box .recentcomments, ul li{
    background:transparent url(../images/skin1/bullet_orange.png) no-repeat scroll 0px 10px;
    border-bottom:1px solid #d6d6d6;
    }

    and also remove this:

    border-bottom: 1px solid #ff9000;

    from

    .wrapper a, #main #sidebar .textwidget a{
    color:#777777;
    border-bottom: 1px solid #ff9000;
    }

    Both in style1.css

    #51805

    Chris,

    I already removed the first code according Dude’s tip.

    I couldn’t find the second code lines in style1.css (even in the distributed and unedited file).

    Any clues?

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Strange layout with li, a and img tags (especially in sidebar and footer)’ is closed to new replies.