Tagged: ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #9862

    I am putting together a small site for our agency’s intranet use, and I’m having a dilemma. I am using the two-sidebar layout. In my left sidebar, I have a widget area posting articles that fall under the category “Congratulations.” However, when I make a new post about it unrelated topic, it shows up in that widget as well. Here is a screenshot of what I’m talking about:

    http://i215.photobucket.com/albums/cc136/mangyK9/screenshot.jpg

    Any what could be causing this?

    #66102

    Hi JPDCSO,

    Can you double check that the sidebar widget only has the Congrats category selected and then do a few more test posts to see if its posting all other categories or only a specific few.

    Thanks,

    Devin

    #66103

    Here is a snapshot of the Widget:

    http://i215.photobucket.com/albums/cc136/mangyK9/screenshot2.jpg

    I do use a plugin called Widget Context, but I have this issue whether or not that plugin is activated. I re-posted an older item that I pulled, and it shows ed up in the sidebar as well. It appears that posts show there regardless of the category I add.

    By the way, thanks for your help!

    #66104

    Question: Would there be another way to post this category without the newscast news sidebar? The only other thing I could think of is that maybe it’s not working with another plugin?

    #66105

    One final clarification: I tried adding another newscast news sidebar widget for a different category, and like the others, it just adds all posts to that section rather than just the one specific category.

    #66106

    More info if this helps: I noticed at the bottom of my widget page are now two blank areas labeled “Category: Congratulations left” and “Category: Congratulations right” … I assume this is tied in with the issue somehow?

    #66107

    Sorry about the confusion! I forgot that this is one of those ‘you learn it once and don’t think anything of it’ pieces of info.

    You need to use the actual category ID and not the name. Go to your posts, select Categories. Click on the Category name you want to get the ID. The URL of that page will be something like:

    /wp-admin/edit-tags.php?action=edit&taxonomy=category&tag_ID=55&post_type=post

    That tag_ID=## is the category ID you want.

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Strange Posting/Widget Issue’ is closed to new replies.