Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7037

    Hello!

    I’ve been working on the site for a little bit and out of the blue I start getting HTTP: 500 error. Only on the front end and only when logged in. We have a “down for maintenance” plugin activated so if you aren’t logged in “back soon” page shows up.

    I’ve done a bunch of testing with permalink resets, .htaccess file and I’ve traced it back to the theme. When I activate another theme the site works fun. When I revert back to the Corona them, same thing happens. I tried disabling the maintenance plugin and it made no difference. I searched the forum and found a post where Dude suggests enabling debug mode and in wp-config.php. I did this and the site returns the following error when I log in and try to load the page:

    “Notice: Use of undefined constant PLUGIN_PATH – assumed ‘PLUGIN_PATH’ in /data/htdocs/c/cloudcontrol/wp-content/plugins/brainbits-flickr-gallery/brainbits-flickr-gallery.php on line 28 Notice: Undefined index: category_exclude in /data/htdocs/c/cloudcontrol/wp-content/plugins/gigpress/gigpress.php on line 579″

    When I disable both those plugins I get a blank white page.

    The weird thing is all of these plugins were working fine with the theme. It seemed to happen out of the blue. The last thing I was doing was adding some extra buttons to the social links menu bar at the top, which I did by copy pasting the code from the other links and creating my own button.

    Very much hoping you can help me out…

    #56383

    Hey,

    try following:

    Open up wp-config.php in the root of the site and look for this line:

    define('WP_DEBUG', false);

    Add this line in its place:

    define('WP_DEBUG', true);

    #56384

    Hey Dude,

    Thanks man but read my comments. I did do that and I got the following message:

    “Notice: Use of undefined constant PLUGIN_PATH – assumed ‘PLUGIN_PATH’ in /data/htdocs/c/cloudcontrol/wp-content/plugins/brainbits-flickr-gallery/brainbits-flickr-gallery.php on line 28 Notice: Undefined index: category_exclude in /data/htdocs/c/cloudcontrol/wp-content/plugins/gigpress/gigpress.php on line 579″

    When I disable both those plugins I get a blank white page.

    The weird thing is all of these plugins were working fine with the theme. It seemed to happen out of the blue. The last thing I was doing was adding some extra buttons to the social links menu bar at the top, which I did by copy pasting the code from the other links and creating my own button.

    Very much hoping you can help me out…

    #56385

    Hi,

    have you tried removing that code you’ve implemented later on? The plugin isn’t recognising a constant in your plugin. If this plugin was working before it must be a change you’ve made recently.

    #56386

    Hey Chris!

    Thanks for your reply! That seemed like such an obvious solution but what I was doing felt so innocuous that I didn’t think for a second that it could be causing the problem. I tried removing the changes I made but it didn’t seem to work. So I replaced the header.php file with the original Corona one and BAM it started working again :)

    Thanks for your help! I will go through my changes line by line until I figure out what was causing it :)

    Joel

    #56387

    Glad it works now. Let us know if you run into any other problems :)

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Sudden Error 500 with Corona Theme’ is closed to new replies.