Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #23259

    Hi,

    on http://www.welsch-lehmann.com/marketing-automation/events/ I have a list of events.

    In column one I have the name of the event linked to the URL of the source.

    When editing the field it works ok to enter the content in the form <a href="http://www.example.com">Example</a>

    BUT when you safe the file you get a backslash in front of the ” every time you safe the table (not the page!) resulting in a URL <a href=\"http://www.example.com\">Example</a>

    We are using Enfold ver 1.3.1

    Thanks,

    Frank

    #119110

    Hi,

    Please download the latest version, Enfold 1.4, on your themeforest account.

    Checking the page, the URL on the first column seems to be working fine.

    Regards,

    Ismael

    #119111

    Oh, I very much hope that my current page works fine. I have corrected all errors before I publish the life page ;-)

    I loaded the current template from themeforrest. The local version.txt states Ver 1.4. However after uploading the Version number still is 1.3.1. ?!

    The URL error ist still present. Check http://www.welsch-lehmann.com/testtable/

    Thanks,

    Frank

    #119112

    Hi,

    I’m talking about this http://www.welsch-lehmann.com/marketing-automation/events/ . The url on that page seems to be working fine.

    The version number may have been forgotten, you can edit that on style.css. You’ll know if you have the Enfold 1.4 if config-woocommerce is present on your theme files.

    Try to use apostrophe instead. Change this code

    <a href="http://www.kriesi.at">Hey</a>

    to this

    <a href='http://www.kriesi.at'>Hey</a>

    It adds back slashes everytime you update or save the options. Let me tag Kriesi and the rest of the support team.

    Regards,

    Ismael

    #119113

    Hi,

    Yes, each time you save the table the // increase , so if save table 20 times will have a lot of /////////

    The single quotes will work if you save the table once and don’t edit it, because after the first save a single slash will be added , and then another , etc.. So save the table but once until the fix.

    That is another example ..

    <a href="\'http://www.example.com\'">Example</a>

    It’s probably preg_replace or some other regular expression doing something , but so far I can’t find it, lol.

    Thanks,

    Nick

    #119114

    Hi!

    thanks for the info. next update will fix the issue. just a matter of adding stripslashes to one of our php files ;)

    Best regards,

    Kriesi

    #119115

    Just checked with 1.5 but the issue with the URL in tables is still unresolved :-(

    Thanks,

    Frank

    #119116

    I tried to reproduce the issue with 1.5 but I couldn’t. Please try to re-install/upload all theme files again – maybe some files are not updated yet. If this still doesn’t solve the problem deactivate all third party plugins and check if this solves the issue. If not, add following code to functions.php:

    //set builder mode to debug
    add_action('avia_builder_mode', "builder_set_debug");
    function builder_set_debug()
    {
    return "debug";
    }

    insert it at the very top after

    global $avia_config;

    Then go to the page which contains the table shortcode and copy the content of the debug field

    Afterwards post it in this forum – you can use the backtick character ` to post it as a raw code snippet.

    #119117

    Hi!

    I did fix the issue and cant reproduce it any longer. did you update the whole theme folder or just single files? make sure that the whole config-templatebuilder folder is updated

    Best regards,

    Kriesi

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Table fields with URL – broken when re-saving page’ is closed to new replies.