Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #19006

    Hi,

    Hi,

    I using the latest version of abundance and my the site is translated in FR and NL and I’m using those plug-ins:

    - woocommerce 1.6.5.2

    WPML Multilingual CMS 2.6.1

    WPML String Translation 1.5.1

    WPML Translation Management 1.4.1

    WPML WooCommerce Multilingual 1.3

    WPML Media 1.2.1

    My problem is that, with the template builder, for the element “products”, this element doesn’t show any product with secondaries languanges.

    How can I fix this?

    here is the site:

    http://www.laboul.com (products are shown)

    http://www.laboul.com/fr/ (no products found)

    thx for your help

    #101717

    Hi,

    Please update as you are using an older version of I think every plugin (all the WPML certainly, and possibly woocommerce too) Are you using WP3.5?

    Would you please set me up a temporary wordpress admin account so that we can get you back on track. My email is usjahm (aaatttt) gmail (dddooottt) com.

    Thanks,

    Nick

    #101718

    Hi!

    WPML and the theme are up to date.

    There is only wordpress which is still in 3.4.

    I will update to 3.5 and see…

    Best regards,

    Peter

    #101719

    Arf, wordpress updated to 3.5.

    Now all my products are shown twice and the links “add to cart” etc of the first product diplayed are disabled. :-(

    http://www.laboul.com/shop/drink-pink/

    Please help , thx

    ps: your account has been created

    #101720

    Afr, shouldn’t really not update wordpress to 3.5. Blog is also broken now.

    Why asking me to update, I wasn’t using any older version exept wordpress 3.4

    #101721

    Ok, sorry, my mistake.

    I didn’t realized there where an update of WPML available.

    The product page is now ok after having updated WPML to his latest version.

    Now I’m using:

    - wordpress 3.5

    – woocommerce 1.6.6

    WPML Multilingual CMS 2.6.3

    WPML String Translation 1.5.3

    WPML Translation Management 1.4.3

    WPML WooCommerce Multilingual 1.4

    WPML Media 1.2.2

    But the blog is still broken. I opened a post to the WPML support for it:

    http://wpml.org/forums/topic/blog-not-displayed-with-abundance-and-woommerce-2/

    So lets back to the first issue, which is, the template builder, for the element “products”, this element doesn’t show any product with secondaries languanges.

    thank you!

    #101722

    Hi,

    Sorry, I am most likely not in your time zone. Looking now. The product doubling is an issue with WooCommerce, but luckily I know of a way to fix it.

    I see no email from you. (Email address hidden if logged out)

    To fix the duplicate content on WooCommerce :

    Edit a file inside woocommerce plugin /templates/single-product.php or you can create an empty folder *inside the theme folder* and call it /woocommerce/ and copy and edit the single-product.php file there so that way it will over-ride the plugin file.

    In either case you will need to replace lines 24-28 that look like

    <?php while ( have_posts() ) : the_post(); ?>

    <?php woocommerce_get_template_part( 'content', 'single-product' ); ?>

    <?php endwhile; // end of the loop. ?>

    with the following

    <?php
    if ( have_posts() ) {
    the_post();
    woocommerce_get_template_part( 'content', 'single-product' );
    }
    ?>

    Thanks,

    Nick

    #101723

    Thx for your support but if you read correctly, the product doubling issue was already fixed.

    I just want some help for the template builder in the secondaries languages.

    thank you

    #101724

    Hi!

    Hi,

    Thank you for your clarification. I thought you needed assistance with WPML and template builder.

    Thanks,

    Nick

    Regards,

    Peter

    #101725

    It is still the case, I need help for the template builder and wpml.

    Can you help me for this?

    ps: credential sent again.

    #101726

    Hi,

    Sorry Laboul. I will get to you right now. Been at it 14 hours.

    Nick

    #101727

    Ok Nick, thanks for your support, you help me a lot.

    All my problems are fixed now.

    #101728

    Hi,

    No problem. Glad you are back on track!

    Thanks,

    Nick

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Template builder: element "Products" with wpml’ is closed to new replies.