Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2857

    Hey guys, I am looking to be able to disable the plugin ‘Sociable’ on my testimonial posts, so it doesnt show up on my home page.

    http://www.jlsclarity.com

    ^ my site. I have disabled the plugin on all other pages that I have widgeted on my home page via a Disable option along the right side of the new post page under the publish button. but on the new testimonial page there is no option to disable. Is there a line of code I can add to allow the plugin options to appear on the new testimonial page?

    Thanks!

    #39555

    You need to modify a plugin file. Open up sociable.php and search for following code:

    function sociable_meta_box() {
    add_meta_box('sociable','Sociable','sociable_meta','post','side');
    add_meta_box('sociable','Sociable','sociable_meta','page','side');
    }

    replace it with:

    function sociable_meta_box() {
    add_meta_box('sociable','Sociable','sociable_meta','post','side');
    add_meta_box('sociable','Sociable','sociable_meta','page','side');
    add_meta_box('sociable','Sociable','sociable_meta','testimonials','side');
    }

    Now the plugin options should be displayed in your testimonial post editor…

    #39556

    Thank you sir!

    #39557

    Actually dude, I dont have that code in my Sociable plugins – I have Sociable3.php – is there a different code Im looking for?

    #39559

    You can use a notepad like notepad++ to search all plugin files. Just search for:

    add_meta_box

    functions and add a line for “testimonials” to it. (Like I did above…)

    #39560

    Worked great! Thanks a lot!

    #39561

    Hey,

    Awesome, let us know if you have any other questions.

    James

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Testimonials page wont allow Sociable plugin disable’ is closed to new replies.