Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #177075

    Hi,

    when i try to open a page with the google maps widget with an mobil device, which connects via a mobile internet connection (not Wifi, everything works on wifi) the following error appears.

    The google Maps API server rejected your request. The sensorparameter specified in the request must be set to either trueor false.

    I already tried to delete and insert it again but it didn`t help.

    I`m looking foward to your answer.

    icos

    #177132

    Hi,

    Can you post the link to your website please?

    Regards,
    Josue

    #177292

    hi,

    thank you for your quick respond.

    the link is: http://www.disg-tipps.de/kontakt

    Regards,

    icos

    #177749

    Hey!

    Can you please post the code for your google map? You can add the sensor parameter at the end of the map url, something like this &sensor=true. If that doesn’t work please edit, framework > php > class-framework-widgets.php, find this code:

    wp_register_script( 'avia-google-maps-api', $prefix.'://maps.google.com/maps/api/js?sensor=false', array('jquery'), '1', false);

    Replace it with:

    wp_register_script( 'avia-google-maps-api', $prefix.'://maps.google.com/maps/api/js?sensor=true', array('jquery'), '1', false);

    Best regards,
    Ismael

    #178320

    hi,

    Thank´s for your respond.
    I use the stock enfold google maps widget. I`m not sure which code I should post.

    Which URL do you mean?

    I replaced the code but it didn´t change anything.

    Regards,

    icos

    #179583

    Hi!

    I can’t really check this on an actual mobile device. Let’s wait for Kriesi’s response.

    Regards,
    Ismael

    #180564

    Hey!

    Seems to be a problem with the connection and not the device – maybe the connection provider manipulates the requested url somehow but our script sends the sensor parameter with

    
    ?sensor=false
    

    Best regards,
    Peter

    #180608

    hi,

    it seems like the error only appears on vodafones mobile connection. I tryed a t-mobile and a eplus device and the error didnt appear.

    thanks for your help

    Best regards,

    icos

    #180651

    Hey!

    Strange, maybe try to contact the vodafone support staff and ask them why the connection doesn’t support the google maps api.

    Cheers!
    Peter

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘The google Maps API server rejected your request’ is closed to new replies.