Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #16606

    Hi,

    I have problems with the images uploaded to the gallery. I can upload images to product/page and I can view the thumbs in the wp-admin, but in the front the images are broken or are not showing.

    I tried to delete all images of the product and upload again but not wors. I tried to create a new prduct but not works… Is it courius, yesterday works fine and today is broken.

    I checked the WordPress media option and I can see the images but the link is different. See the images linked below below:

    http://www.creagamma.com/fuelmoto/errors/screen1.png

    http://www.creagamma.com/fuelmoto/errors/screen2.png

    You can check the page at:

    http://www.creagamma.com/fuelmoto/?product=new-sweatshirt-maroon (not works)

    http://www.creagamma.com/fuelmoto/?product=new-t-skullracer (works) uploaded yesterday

    Thanks :-)

    #92170

    I’ve been having this same problem, too. Started up a few days ago…

    #92171

    Hi,

    I guess it has something to do with media_upload_url on framework > php > class-media.php but I can’t be sure and I don’t know how to fix it. Let me tag the rest of the support team to help us out.

    Regards,

    Ismael

    #92172

    Hi,

    Are you using latest version of WordPress? Have your .htaccess file been changed? Sounds like your rewrite rules need to be looked at. Have you installed something new or changed settings? Make sure you deactivate any plugins which didnt come with the theme. Have you scanned your website for malware? Consider doing a re-install with a fresh database, new WordPress and a new copy of the theme.

    Thanks,

    Nick

    #92173

    Hi all,

    Nick, I will answer to your questions:

    Are you using latest version of WordPress?

    I’m using WordPress 3.4.1 and WooCommerce 1.6.1

    Have your .htaccess file been changed?

    This is the content of my .htacces (not changed)

    <br />
    <IfModule mod_rewrite.c><br />
    RewriteEngine On<br />
    RewriteBase /fuelmoto/<br />
    RewriteRule ^index.php$ - [L]<br />
    RewriteCond %{REQUEST_FILENAME} !-f<br />
    RewriteCond %{REQUEST_FILENAME} !-d<br />
    RewriteRule . /fuelmoto/index.php [L]<br />
    </IfModule><br />

    Have you installed something new or changed settings

    No, is completly new installation and only I edited the basic settings (freshlight panel options, and custom.css file)

    Make sure you deactivate any plugins which didnt come with the theme

    Only I have this plugins installeds: Askimed (not active), Hello Dolly (not active), WooCommerce (following your theme instructions) and WooCommerce Table Rate Shipping.

    Consider doing a re-install with a fresh database, new WordPress and a new copy of the theme.

    Done, this is my second attempt, and in another server…. And for secodn time I have the same error. You can see my first attempt here:

    http://www.creaticus.es/fuelmoto/?post_type=product

    You can see a product without image, is where there something is broken

    Have you scanned your website for malware

    I tried to run in two differents servers… and the problem persists.

    I would add that today I was able to add pictures without problems. But is not working 100% I have an order in the gallery 1, 2, 3… but the front is not respecting it. I tried to reorder again but not works.

    This is my second post requesting techincal support and I don’t have the site working fine… I dedicated a couple of hours understanding the procedures to add items… and I done the same tasks some times.

    Generally I think there are some bugs to solve and test a little bit more the functions and improve some things.

    Please, consider these words to help you to improve.

    I wait for your comments,

    legogr

    #92174

    Hi,

    Thank you for the advice. Please add this to the beginning of you .htaccess file, before the block that you currently have there. The block ensures that the server remembers how to handle various file types.

    Thanks,

    Nick

    #
    
    # Proper MIME type for all files
    #

    # JavaScript
    # Normalize to standard type (it's sniffed in IE anyways)
    # tools.ietf.org/html/rfc4329#section-7.2
    AddType application/javascript js jsonp
    AddType application/json json

    # Audio
    AddType audio/ogg oga ogg
    AddType audio/mp4 m4a f4a f4b

    # Video
    AddType video/ogg ogv
    AddType video/mp4 mp4 m4v f4v f4p
    AddType video/webm webm
    AddType video/x-flv flv

    # SVG
    # Required for svg webfonts on iPad
    # twitter.com/FontSquirrel/status/14855840545
    AddType image/svg+xml svg svgz
    AddEncoding gzip svgz

    # Webfonts
    AddType application/vnd.ms-fontobject eot
    AddType application/x-font-ttf ttf ttc
    AddType font/opentype otf
    AddType application/x-font-woff woff

    # Assorted types
    AddType image/x-icon ico
    AddType image/webp webp
    AddType text/cache-manifest appcache manifest
    AddType text/x-component htc
    AddType application/xml rss atom xml rdf
    AddType application/x-chrome-extension crx
    AddType application/x-opera-extension oex
    AddType application/x-xpinstall xpi
    AddType application/octet-stream safariextz
    AddType application/x-web-app-manifest+json webapp
    AddType text/x-vcard vcf
    AddType application/x-shockwave-flash swf
    AddType text/vtt vtt

    #92175

    Where would the htaccess file be located? I’m still having issues with the Image Gallery and none of the things you mentioned have occurred.

    #92176

    Hi,

    .htaccess can be found on your root folder with wp-content, wp-admin and wp-includes folders.

    Regards,

    Ismael

    #92177

    Hi legogr,

    I just wanted to add that it looks like you are using kind of an in between version of WooCommerce. The most recent version of flashlight was last updated for version 1.5.8 of WooCommerce and some things that changed in the plugin at version 1.6 needed to be updated and modified by WooThemes to offer better backwards compatibility.

    First, try updating your version of the plugin to the most recent version available or if you want to ensure no issues and are ok with running an older version of the plugin download and install version 1.5.8 from the download for it here: http://wordpress.org/extend/plugins/woocommerce/developers/

    If however the fixes above have you all sorted out, ignore this and another theme update should be coming out in the next few weeks.

    Regards,

    Devin

    #92178

    Buggers… I looked there, didn’t see anything, so I used the search tool. The search results show .htaccess directly in my public_html folder, however… it’s not there when I view the folder. I’m at a loss…

    #92179

    I’m reaching a point where I’m getting more frustrated working with this theme & questioning the value… I LOVE how it looks, but the Image Gallery issue is HUGE.

    1. If I don’t have images in the image gallery, the Related Posts within the blog pages have a big blank square w/ magnifying glass in them.

    2. If I can’t use the image gallery, and try to put an image into the page itself, I end up with the white page background and a title that I don’t want (for my home page).

    3. The Save Changes button within the Image gallery is ever present, but the “…then close the window and update the gallery preview” button constantly disappears, forcing me to X out of the image gallery, click Upload, click Gallery, and then hit Save Changes and “close the window” button (why it works then and not the first time I upload an image, I haven’t a clue.)

    4. And sometimes the Image Gallery works and I can actually see the image as background on the page, and sometimes it doesn’t. Like just now, I tried to change the image and use a different one. It worked with the old image, but now is broken with the new one.

    Super frustrated and I know that you all are great at helping here, but… I am wasting so much time coming back here for issues that a lot of other things I need to do for my business are getting shoved aside. :(

    Is there ANYTHING that can be done about this situation? I haven’t changed anything within my WP to make this happen (plugins, etc.)

    Thanks for any insight, help, etc. As I said, I love how my theme looks, but the frustration with it is just reaching an unacceptable point.

    #92180

    I can’t say for sure what might be happening but the process is usually a bit more straightforward than that for products. The images do need to be in the themes own image gallery so that the theme can properly manipulate them. The only alternative to that is a plugin and a bit of modification to use the media gallery instead( see: http://inoplugs.com/tutorials/how-to-use-the-media-gallery-in-combination-with-flashlight/ )

    It sounds like there are issues on your server/computer/browser that are causing and disconnect between how the theme should work and how it *is* working for you. Unfortunately, figuring out what this is exactly is a bit difficult. The more details on exactly what is happening, what circumstances cause it to repeat etc the better we can try to help.

    As for the .htaccess file, it may be that it is hidden via FTP or whichever mechanism you are using to access your sites root folder. In that case, contact your hosting provider and let them know what you are trying to do and see if they can assist you in modifying/adding to your htaccess file.

    Regards,

    Devin

    #92181

    Hi Chaps, this is the first time of posting on any forum for me and I am not really very technical. I have familiarised myself with the theme and woo commerce fairly well but am a little confused as to why the images I upload to the new product page > gallery options > gallery do not appear as a gallery like the live example on theme forest of flashlight.

    I have just installed the latest version of wordpress, flashlight and woo commerce about a week ago. I thought you might have to add a short code in to the product description to get it to work, but after a bit of digging found this thread. I am not a programmer and to be honest most of this thread has gone completely over my head but will be keeping an eye on this thread to see if there is an update to flashlight or woo commerce so us mortals can get it fixed. I have not changed any code (as I have no idea what i’m doing there) I may possibly have changed a setting some where but I don’t think so. The rest of the theme is really straight forward, it’s just this that seems like it just doesn’t work. I have tried putting the short code slider in the product description which is a reasonable bodgit and scarper fix but not ideal when it is built in to the theme and should work.

    I would really appreciate any help, let me know your thoughts

    http://www.webbstar.co.uk (work in progress) :)

    #92182

    Hi Webbstar,

    On the individual product, you need to add your images to the gallery manager that is just below the visual editor. Then choose an option for how the gallery should display other than the default one of “as a background slideshow only” so that the product image appears on the actual product page.

    Regards,

    Devin

    #92183

    Hi Devin

    Thank you for your response. How ever this is where I have put the images. as far as I can tell I have done everything as it is supposed to be done but it just doesn’t show the images on the front end. I believe the only setting where it does show the images is when i choose wordpress default gallery, this only shows one image though. I tried to add a screen grab to this post but this isn’t possible.

    Any other ideas?

    Thanks Devin

    Webbstar

    #92184

    Can you create a temporary admin account for me so I can login and take a look?

    You can send the information to my email at DevinVinson (at) gmail.com. Make sure to include a link to this topic so that my spam filter doesn’t grab it :)

    Regards,

    Devin

    #92185

    Hi Devin

    Just mailed it to you, thanks for your help

    Webbstar

    #92186

    Hi Devin

    Just a quick post to say thanks, problem fixed. For anyone else reading this. The problem was solved by updates. As I had only just downloaded the theme I must have missed the update by hours.

    Webbstar

    #92187

    Glad we could help and sorry for not catching that earlier :)

    Let us know if you have any other questions or issues.

    Regards,

    Devin

Viewing 19 posts - 1 through 19 (of 19 total)

The topic ‘The image gallery is broken’ is closed to new replies.