Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #176361

    Hi,

    I made another topic about this subject but it was not resolved and I found out it’s closed now so I start this new one.

    I have a big problem because my post show comments number when there are none. Please look a t the picture in the link above:

    https://www.dropbox.com/s/93lcql167ry466c/Accueil_-_wordpress_et_webdesign_par_Christelle_Bourgeois.jpeg

    You told me it was due to wp-rocket plugin but after I investigated and disabled the plugin it appears it’s not coming from it.
    Can you solve this problem please? It’s very annoying and bad for readers to go on my site , think there are comments on an article and find out there are none.

    Kind regards,

    Chrys

    #176839

    Hello chryseis!

    Can you please give us a link to the website? Go to Dashboard > Home > Recent Comments > Remove everything including the Trash.

    Cheers!
    Ismael

    #176980

    Hi,

    I made some tests and the problem comes from the latest comment in homepage and with the posts on the right.

    I explain:

    I want three posts in latest articles on my homepage.
    If the first post on the left have comments they won’t show. If the one in the middle have some, they won’t show (actually I have two but you can see it’s written 1) If the post on the right have comments, the number of comments will be attributed to the other posts.
    Here one everywhere like on the picture. So it’s the post on the left that commands the other one.
    But if you go the blog page, you’ll see that everything is as it should. So the problem comes from the “last post section” i have added on my homepage…

    https://www.dropbox.com/s/93lcql167ry466c/Accueil_-_wordpress_et_webdesign_par_Christelle_Bourgeois.jpeg

    How can I fix that?

    Kind regards,

    Chrys.

    #176984

    Ps: website url: http://www.calliframe.com

    #177553

    Update:

    Now the posts have all 2 comments because the last article on the right have two.
    Please I really need a fix on this. It’s a question of credibility, if readers go on my site and want to read the comments on my articles because it says there are some, and they go and they see none they will think it’s false publicity.

    Kind regards,

    Chrys

    #178333

    Hi!

    Please create us an admin account and post the login credentials as private reply. We’ll look into it.

    Best regards,
    Peter

    #178372

    Hi,

    Id: kriesi
    password:enfoldkriesi

    I hope you can help.

    I had another problem this morning . After doing the update all my icons in the whole theme on all my pages where there are some had disappeared. It’s seems ok now. Maybe it was because the update needed some time to be effective. But still if you could tell me that you see them correctly on your side it would be a relieve to know you don’t notice something wrong.

    Kind regards,

    Chrys.

    #178386

    Hey!

    Ok I debugged the issue and it seems to be a problem/bug with the WPML plugin. Kriesi uses following code in /wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/postslider.php

    
    $commentCount = get_comments_number($the_id);
    

    to query the comments number. This function seems to work when WPML is deactivated but it breaks when WPML is activated (at least it doesn’t seem to accept the id parameter). However the other functions (i.e. get_permalink() or get_the_post_thumbnail()) work just fine and I think the WPML plugin doesn’t return the right comment count when the get_comments_number() is used within a loop. Please contact the WPML plugin authors and ask them to look into it (you can also link to this post) because I think this is something which needs to be fixed in the WPML core plugin code.

    Best regards,
    Peter

    #178390

    Hi!

    Just a side note – I temporarily fixed it by replacing

    
                        $commentCount = get_comments_number($the_id);
    

    with

    
                        //$commentCount = get_comments_number($the_id);
                        $commentCount = $entry->comment_count;
    

    however it’s just a workaround because the get_comments_number() still doesn’t work…

    Regards,
    Peter

    #178401

    Hi,

    I have actually noticed many problems with the WPML plugin I have lost some authorization on some extension of this plugin …
    I was planning to desinstal it completely and try to reinstall it afterward.
    No that you have done something to resolve the problem, do you think that if I delete the plugin and reinstall it , it will interfere with what you have just done?

    I’ll wait for your answer to see if I delete the plugin or if I see directly with WPML before.

    Kind regards

    Chrys

    #179024

    Hi,

    BIG PROBLEM since you went on my site. Please help me to fix it.
    Since you went on my site to help me deal with the problem above I have now this message:

    Your backup folder MIGHT be visible to the public

    To correct this issue, move the .htaccess file from wp-content/plugins/wp-dbmanager to /homez.726/callifra/www/wp-content/backup-db

    What does it say that?

    Kind regards

    Chrys

    #179026

    SORRY!!!! Don’t consider the previous message. You actually activated the plugin wp db manager that I don’t use anymore.

    But still can you tell me if I uninstall WPML completely will this mess up the fix you did yesterday?

    Kind regards

    #179558
    #180762

    Hi Peter,

    Thanks for the link!

    cheers.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘The post still shows 8 comments when there are none’ is closed to new replies.