Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #26990

    Hi, I found the problem I had with IE9 and IE10 (I guess with IE8 is the same).

    Your site does not look good when this mode is on “compatibility view”.

    I modified two computers with IE9 and IE10 and now looks perfectly.

    You could add to the new versions of the theme one FIX to be able to not work with compatibility view mode is active even in the browser?, I mention because by default with IE9 and IE10 is activated and thus avoid the users (which not usually technical) having to touch browser that option ….

    Thank you!

    Xavier.

    #132357

    I did not test it yet but you can try the suggested code here: http://stackoverflow.com/questions/6348959/how-to-disable-compatibility-view-in-ie

    In header.php replace

    </head>

    with

    <meta http-equiv="X-UA-Compatible" content="IE=10; IE=9; IE=8; IE=EDGE" />
    </head>

    #132358

    Hi Dude,

    Now is with these changes and don’t works……….;__(

    #132359

    Hi xpoveda,

    Compatibility mode is not turned on by default and should only ever show up for users that have it turned on or if somehow IE has an error rendering your pages content.

    See: http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-10

    Regards,

    Devin

    #132360

    You can also try this hack here: http://www.cfelements.com/2010/06/detecting-and-correcting-ie8-in.html

    Maybe the code I posted above is not valid and the content attribute just supports one browser. Then IE=100 should overwrite all browsers up to v99 :)

    <meta http-equiv="X-UA-Compatible" content="IE=100" />

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘THE SOLUTION FOR PROBLEMS WITH IE (COMPATIBILY VIEW JUST THE OPPOSITE)’ is closed to new replies.