Tagged: ,

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #20115

    Hi, I’m using Sentence theme for my client website and it cannot be open now with this error:

    Warning: html_entity_decode() [function.html-entity-decode]: charset `UTF-7′ not supported, assuming iso-8859-1 in /home/muarajam/public_html/wp-content/themes/sentence/framework/php/function-set-avia-backend.php on line 506

    What to do? Since I’m not too fluent in coding and programming.

    Thanks!

    #106354

    Hey!

    Never seen something like this happen before, I think UTF-7 isnt even a valid charset.

    Please open the admin panel of your website and in the browser bar enter the page “/wp-admin/options.php”

    This will take you to the advanced options page of your WordPress installation.

    Now search for the entry: “blog_charset” that one should read UTF-8. If it doesn’t please try and change it. If it already shows UTF-8 or changing doesnt fix the problem let me know

    #106355

    Actually, it is already written utf-8.

    #106356

    Probably you need to use a database tool to change the value manually. Use a db management tool like phpmyadmin, open your database and search for the “blog_charset” option (without “”) in the wp_options table. Click on “Edit” and make sure that it’s set to “UTF-8″ (without “”).

    If this doesn’t help you’re probably a victim of a hacker attack and the hacker modified your theme/wordpress files. In both cases update your theme to the latest version – we fixed a serious security issue (XSS vulnerability) in the past. I’d also re-upload all WordPress core files. You can download the latest theme version at themeforest.net – make sure that you replace all php files, including functions.php, index.php, header.php and footer.php

    #106357

    Hey! To elaborate a little bit:

    Setting a Websites Charset to UTF-7 seems to be a common way for hackers to bypass input validation. Depending on when you have uploaded the theme it might be possible that you are using a version that has a XSS Vulnerability. If you have updated your theme in the last 3 Months you should be save from that angle but then you should definitely consider checking all other plugins and software on the server.

    Cheers!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Theme error!’ is closed to new replies.