Tagged: , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #211308

    Hi!
    I have translated parts of the po-file into Swedish, considering that some of my translations don’t show up in the frontend, see image:
    Translation strings
    As you can see in the image “(previous entry)”, among others, is not translated (yes, this string is translated in the po/mo-files). The translation of “Related Entries” is shown.
    I don’t want to hardcode the translations, but what to do?
    Thans in advance!
    // Andreas

    #211592

    Hey miehling!

    Kriesi forgot the textdomain. We’ll fix this in the next update. For now open up /wp-content/themes/angular/includes/loop-portfolio-single.php and replace

    
    						<div class='previous_post_link_align'>
    							<?php previous_post_link('<span class="previous_post_link">&larr; %link </span><span class="post_link_text">'.__('(previous entry)')."</span>"); ?>
    						</div>
    						<div class='next_post_link_align'>
    							<?php next_post_link('<span class="next_post_link"><span class="post_link_text">'.__('(next entry)').'</span> %link &rarr;</span>'); ?>
    						</div>
    

    with

    
    						<div class='previous_post_link_align'>
    							<?php previous_post_link('<span class="previous_post_link">&larr; %link </span><span class="post_link_text">'.__('(previous entry)','avia_framework')."</span>"); ?>
    						</div>
    						<div class='next_post_link_align'>
    							<?php next_post_link('<span class="next_post_link"><span class="post_link_text">'.__('(next entry)','avia_framework').'</span> %link &rarr;</span>'); ?>
    						</div>
    

    Then download: http://wordpress.org/plugins/codestyling-localization/

    Install the plugin, go to Tools > Localization and select “Themes”. Then search for “Angular” in the list and click on “Add new language”. Then select your language from the list and click the “create po-file” button. Click on “Rescan” to search for all text strings. Then click on “Edit” and translate the required strings from the “avia_framework” textdomain. At least click the “create mo file” button next to the “Textdomain” selection dropdown (top left corner).

    Best regards,
    Peter

    #213894

    Hi again!

    I had already translared the po/mo-files, so adding the text domain worked just fine.

    Thanks for your fast support!

    Kind regards
    Andreas

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Theme translation via po/mo-files: some translations don't show up’ is closed to new replies.