Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #188330

    I have tried to translate the Replete theme by downloading and change the default .mo and .po file but I noticed later it did not contain any swedish translations. When I open the translation editor in codestyling localization no words were translated for neither replete or woocommerce. When I tried to add the language again I got a warning sign saying something is wrong with the file.

    How can we proceed?

    • This topic was modified 11 months, 2 weeks ago by  MacRyhage.
    #189220

    Hey Marcus!

    Please try to use Codestyling instead: http://wordpress.org/plugins/codestyling-localization/
    Install the plugin, go to Tools > Localization and select “Themes”. Then search for “Replete” in the list and click on “Add new language”. Then select your language from the list and click the “create po-file” button. Click on “Rescan” to fetch all text strings. Then click on “Edit” and translate the required strings from the “avia_framework” textdomain. At least click the “create mo file” button next to the “Textdomain” selection dropdown (top left corner).

    Best regards,
    Peter

    #189302

    Hey Peter,

    Thanks for your reply but that is exactly what I have been trying to do. I use Codestyling Localization but no words gets translated when I scan and I get this message:

    Warning: The actual loaded translation content contains mixed textdomains and is not pure translateable within one textdomain.
    It seems, that there is code contained extracted out of other plugins, themes or widgets and used by copy & paste inside some source files.
    The affected unknown textdomains are: wordpress-importer, woothemes, woocommerce

    Is there anything wrong with the translation or can I make some adjustements to make the import function better?

    • This reply was modified 11 months, 2 weeks ago by  MacRyhage.
    #189517

    Hi!

    Do you have any other plugins installed? Please deactivate them first then try to translate the strings again. Please post the login details here as a private reply.

    Best regards,
    Ismael

    #189524
    This reply has been marked as private.
    #190178

    Hey!

    You are currently using Replete version 1.4.1. Please update it to the latest version 1.5. You should login on ThemeForest with the account you have purchased Replete theme and go to Downloads section to download the latest version. Let us know if issue remains after the update
    For a quick guide on updating your theme take a look at this video on updating the theme via FTP: https://vimeo.com/channels/aviathemes/67209750

    Cheers!
    Yigit

    #190643
    This reply has been marked as private.
    #190926
    This reply has been marked as private.
    #191373

    Hey!

    1) You must use the Swedish version of WordPress (see: http://sv.wordpress.org/ ) otherwise the Swedish translation file won’t load (even if everything is translated). As long as the admin panel is in English you’re using the English version of wordpress.

    2) You didn’t translate the the theme po file yet. It seems like the old translate file is not compatible with Codestyling – thus you need to translate all strings here: http://www.bodybooster.se/wp-admin/tools.php?page=codestyling-localization/codestyling-localization.php&type=themes#mo-list-1

    After you translated the string generate the mo file (generate mo file button). You just need to translate the avia_framework textdomain (already selected in the dropdown) and you can ignore the warning and the other text domains. If you’re ready with the translation please provide a link to the po fileand we’ll include it with the next update for all Replete users.

    Regards,
    Peter

    • This reply was modified 11 months, 1 week ago by  Dude.
    #191443

    I cant see your message, it says its marked as private even when I am logged in. Has there been some error or do I have to do something to view it?

    #191462

    Hey!

    I removed the “private” flag. You should be able to read it now.

    Regards,
    Peter

    #191875

    Ok, thanks.

    • This reply was modified 11 months, 1 week ago by  MacRyhage.
    #192850

    Hi!

    Please let us now if you need more help regarding this issue.

    Cheers!
    Peter

    #198092
    This reply has been marked as private.
    #198519

    Hey!

    1) The reviews etc. are part of the woocommerce plugin and you can’t translate them with the theme files. You probably need to translate the plugin translation file ( /wp-content/plugins/woocommerce/i18n/languages/woocommerce-admin-sv_SE.po ) – use the Codestyling plugin to rescan and translate the woocommerce file.

    2) Insert following code into the quick css field to remove it

    
    .single-product .title_container { display: none; }
    

    3) Use following css code to hide the sidebar

    
    .archive.woocommerce .sidebar.sidebar_right { display: none; }
    .archive.woocommerce .template-shop.content{width: 100% !important;}
    

    4) In replete/config–woocommerce/config.php delete following line to remove the related products

    
    add_action( 'woocommerce_after_single_product_summary', 'avia_woocommerce_output_related_products', 20);
    

    5) If you use the dynamic template builder you can use the “headline” element to add a headline before or after the product slider or product grid element.

    Cheers!
    Peter

    #199015
    This reply has been marked as private.
    #199454

    Hey!

    1) Afaik you need to set the order on the WooCommerce > Settings > Catalog page (select “Default sorting (custom ordering + name)” in the dropdown field). If it doesn’t work try to use: http://wordpress.org/plugins/post-types-order/ or use the WooCommerce sort feature (Products > Sort Products tab).

    2) Insert following code into the quick css field

    
    #top .description ol, #top .description ul {
    list-style: disc inside !important;
    }
    

    Best regards,
    Peter

    #199929
    This reply has been marked as private.
    #200193

    Hi!

    I added an !important tag and removed the summary selector – please try the code again.

    Regards,
    Peter

    #200205
    This reply has been marked as private.
    #200311

    Hey!

    Please try this one:

    .summary.entry-summary ul li {
    list-style: disc inside !important;
    }

    Cheers!
    Ismael

    #200342

    Great, that worked perfectly!

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Translate Replete and Woocommerce to swedish’ is closed to new replies.