Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #182571

    I’ve found a couple of posts here on how to disable the lightbox feature for images in the Enfold theme – I’ve commented out the two lines in the avia.js file (lines 53 & 54) and actually commented out the entire Lightbox activation function (at line 450). I cleared the site’s cache as well as the local cache and the lightbox is still showing. Is there another update that I need to make i order to turn this off?

    Thanks!

    #183391

    Hi awsystems!

    If you have commented out the lightbox activation in the javascript file then the lightbox is coming from something outside of the theme. Make sure you don’t have any other plugins with lightbox functions in them and that the server doesn’t have any caching as well.

    Just in case, make sure any changes you are making to the avia.js file are on the live server and not local. Its an often overlooked step to check.

    Regards,
    Devin

    #183520

    Thanks, Devin – I figured out that commenting out the code was actually disabling the lightbox – what I hadn’t realized was that when we insert an image into a page using the Add Media button that by default the image is created as a link to the image. I’ve looked for a way to change this so the default is that the image links to nothing but i’m not finding that setting. Any advise would be awesome.

    Thanks!
    Doug

    #183523

    Actually – found a hack for this. I added the following to the end of the functions-enfold.php file:

    update_option(‘image_default_link_type’,'none’);

    This sets the default option to None when inserting media – I dislike making changes to the settings file as they get wiped out when the theme is updated. I had to make another hack like this to move the Search icon to the Utility Menu – would be an awesome add if the media default could be in the theme settings.

    Thanks again!
    Doug

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Turning off lightbox effect on images’ is closed to new replies.