Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #8975

    I’m using the Twitter widget, but it is reflecting tweet times about 7 hours ahead of where I am.

    I can *confirm that my WP settings are accurate and set to my local time.

    Is this widget pulling from a setting in your AviaFramework?

    Where can I modify?



    You can modify the twitter widget code – it’s located in frameworkphpclass-framework-widgets.php – search for following code to find the right code line:

    $response = wp_remote_get( ''.$username );


    I found it – but what needs to replace this code so that it accurately reflects my timezone for tweets?


    I’m not very familiar with the twitter api but according to the docs: I guess that it’s not a problem with Kriesis code but a twitter account configuration issue. The theme code uses the utc offset (see following line:)

    'utc_offset' => (int) $tweet->user->utc_offset[0],

    to calculate the tweet times. However this offset and the time zone, etc. are part of the twitter response. Please check if all twitter account settings are configured right (especially your time zone) and change them if necessary. Your twitter response file: indicates that the time zone is set to GMT +/- 0.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Tweet time stamp (wrong time zone)’ is closed to new replies.