Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16952

    Hello,

    I have 1 hour of difference between the time of my tweet on my Twitter acount and twitter widget on my website under Choice… The time parameter is the same on my wordpress and twitter acount… Anyone have a idea about this problem? Thanks

    #93531

    Maybe you need to change the UTC offset or the daylight saving time setting? You can “hardcode” the time difference if required though – search for following code in choicesframeworkphpclass-framework-widgets.php:

    if($time == "yes") $output .= '<div class="tweet-time">'.date_i18n( $time_format, $message['created'] + $message['user']['utc_offset']).'</div>';

    and replace $message with:

    $message['user']['utc_offset'] + 3600

    or

    $message['user']['utc_offset'] - 3600

    (the first code will add one hour to the offset, the second one removes one hour).

    #93532

    Hi solljul,

    I can’t say for sure but it might be using your server time instead of twitters. You can check with your web host to see what the server time is set to and that may be it.

    Regards,

    Devin

    #93533

    Hi!

    Thanks for your answers!

    Devin, I had check with my web host and the server’s time is OK, I think it’s about summer/winter time… I’ll see at the end of this month :o) The UTC WordPress setting was OK and Twitter account time setting too…

    But Dude, yout tip works fine for me, thank you very much!

    Best regards.

    Jul

    #93534

    Hi!

    Glad that we could help you :)

    Regards,

    Peter

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Twitter widget time’ is closed to new replies.