Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #21611

    Hi,

    I updated to WooCommerce 2.0 today and now I am getting the following error message on all of my product pages in the section where the related products would be.

    “Warning: uasort() [function.uasort]: The argument should be an array in /home/restin/webapps/wp/wp-content/plugins/woocommerce/woocommerce-template.php on line 791″

    I hid the Related Products section a few months ago using this CSS:

    #top.single-product .related.products {

    display: none;

    }

    And I hid the related products flag by editing the WC .config file with the following:

    Replace: echo avia_flag(__(‘Related Products’, ‘avia_framework’));

    echo $content;

    With: //echo avia_flag(__(‘Related Products’, ‘avia_framework’));

    //echo $content;

    I have removed both of the customizations mentioned above with no effect on the error message. Please help!

    #112447

    1) If you’re using any WooCommerce extensions please deactivate them and check if these extensions output the warning message.

    2) Make sure you’re using the latest version of the theme. Only Propulsion 1.9 and newer versions will work with WooCommerce 2.0.

    3) If 1) + 2) don’t help open up wp-contentthemespropulsionconfig-woocommerceconfig.php and replace:

    remove_action( 'woocommerce_product_tabs', 'woocommerce_product_description_tab', 10 );
    remove_action( 'woocommerce_product_tab_panels', 'woocommerce_product_description_panel', 10 );

    with:

    //remove_action( 'woocommerce_product_tabs', 'woocommerce_product_description_tab', 10 );
    //remove_action( 'woocommerce_product_tab_panels', 'woocommerce_product_description_panel', 10 );
    add_filter( 'woocommerce_product_tabs', 'avia_wc_tabs' );

    and at the very bottom of the file insert:

    function avia_wc_tabs( $tabs ) {
    unset( $tabs['description'] );

    return $tabs;
    }

    #112451

    Has there been any updates for this yet? Same problem here after updating. or does anyone have the old version of woocommerce

    #112452

    Hi intheattic,

    You can always download old versions of plugins from wordpress and for woocommerce its here: http://wordpress.org/extend/plugins/woocommerce/developers/

    However, if you’ve updated your database, you are unable to downgrade from WooCommerce 2.0+ as its not backwards compatible.

    The above fixes should fix this issue however.

    Regards,

    Devin

    #112453

    Hi,

    Just updated the theme to 1.9 and resolved the problem. Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘uasort() Argument Missing after WooCommerce 2.0 Update’ is closed to new replies.